UVA 10106 - Product

10106 - Product

 

The Problem

The problem is to multiply two integers X, Y. (0<=X,Y<10250)

The Input

The input will consist of a set of pairs of lines. Each line in pair contains one multiplyer.

The Output

For each input pair of lines the output line should consist one integer the product.

Sample Input

 

12
12
2
222222222222222222222222

 

Sample Output

 

144
444444444444444444444444

# include <stdio.h>
# include <stdlib.h>
# include <string.h>

#define MAXN 1000

int a[MAXN];
char s1[MAXN], s2[MAXN];

int main ( ){
    int i, j, p, len1, len2;
    while(scanf("%s %s", s1, s2) == 2){
        memset(a, 0, sizeof(a));
        len1 = strlen(s1); len2 = strlen(s2);
        for(i=len1-1; i>=0; i--)
            for(j=len2-1, p=len1-1-i; j>=0; j--){
                a[p++] += (s1[i]-'0')*(s2[j]-'0');
            }
        for(i=0; i<MAXN; i++){
            a[i+1] += a[i]/10;
            a[i] %= 10;
        }

        for(i=MAXN-1; i>=0; i--) if(a[i]) break;
        if(i==-1) printf("0");
        else for(; i>=0; i--) printf("%d", a[i]);
        putchar('\n');
    }

    return 0;
}

 



转载于:https://www.cnblogs.com/tanhehe/archive/2013/01/12/2883513.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值