ACM 01背包问题

Description

The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before retiring to a comfortable job at a university. 


For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible. 


His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.
 

Input

The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj and a floating point number Pj . 
Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .
 

Output

For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set. 

Notes and Constraints 
0 < T <= 100 
0.0 <= P <= 1.0 
0 < N <= 100 
0 < Mj <= 100 
0.0 <= Pj <= 1.0 
A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.
 

Sample Input

3
0.04 3
1 0.02
2 0.03
3 0.05
0.06 3
2 0.03
2 0.03
3 0.05
0.10 3
1 0.03
2 0.02
3 0.05
 

Sample Output

2
4
6
 
解题思路:
题目的大意是,Roy想要抢劫银行,每家银行多有一定的金额和被抓到的概率,知道Roy被抓的最大概率P,求Roy在没有被抓的情况下,抢劫最多 的钱数。这是一个背包问题,我们只要做一点转化。把每个银行的储钱量之和当成背包容量,然后概率当成价值来求。这里是被抓的概率,我们把他转化成不被抓的概率,然后这里的和就可以转化成乘积了。然后利用01背包的模版就可以做出来了。
程序代码:
#include<cstdio>
#include <iostream>
#include<cstring>
using namespace std;
int money[101] , nkind  , sum ;
float pro[101] , npro , fine[11100];
int main ()
{
    int cas,i, j ;
    scanf ( "%d" , &cas ) ;//案例数
    while ( cas -- )
    {
          sum = 0 ;
          scanf ( "%f%d" , &npro , &nkind ) ;//最高的概率数,和银行数
          for ( i = 0 ; i < nkind ; i ++ )
          {
              scanf ( "%d%f"  , money+i, pro+i ) ;//银行钱数和被抓的概率数
              sum += money[i] ;
          }
          memset( fine , 0 , sizeof (fine) ) ;
          fine[0] = 1 ; //背包中的钱为0时,是最安全的,所以安全概率为1
          float  p = 1 - npro ;//最低安全概率
          for ( i = 0 ; i < nkind ; i ++ )//银行数
          { 
              for ( j = sum ; j >= money[i] ; j -- )//
                  if ( fine[j] < fine[j-money[i]]*(1-pro[i]) )//抢到j元钱的安全概率为fine[j]
                  {
                       fine[j] = fine[j-money[i]]*(1-pro[i]) ;
                  }
          }
          for ( i = sum ; i >= 0 ; i -- )
              if ( fine[i] >=  p )//安全的概率大于等于被抓的最低概率时
              {
                   printf ( "%d\n" , i ) ;
                   break ;
              }
    }
    return 0 ;
}

  

转载于:https://www.cnblogs.com/xinxiangqing/p/4725520.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值