dp补题记录3

01背包

 HDU - 2955 

The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before retiring to a comfortable job at a university. 


For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible. 


His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.

Input

The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj and a floating point number Pj . 
Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .

Output

For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set. 

Notes and Constraints 
0 < T <= 100 
0.0 <= P <= 1.0 
0 < N <= 100 
0 < Mj <= 100 
0.0 <= Pj <= 1.0 
A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.

Sample Input

3
0.04 3
1 0.02
2 0.03
3 0.05
0.06 3
2 0.03
2 0.03
3 0.05
0.10 3
1 0.03
2 0.02
3 0.05

Sample Output

2
4
6

 

 

01背包问题的小小变种,概率dp,由于正常的01背包的一个参数这里是以概率表示,数据类型为浮点数,很难以数组下标的形式标识,所以考虑用全放进去的价值作为一维数组的下标,注意一维数组的01背包问题的dp需要倒序保证每个数只取一次,用计算概率的公式作为状态转移方程使相同sum时的不被抓的概率最大。比较求出最大sum即可。

(dp好难啊~)

wa了好多发,明天把对拍搞明白不然有时候很尴尬。

#include <bits/stdc++.h>

using namespace std;
int main()
{
    int T;
    cin >> T;
    while(T--)
    {
        int n,m,sum=0;
        float p;
        cin >> p >> m;
        int a[m+5],b[m+5];
        float c[m+5];
        for(int i=1;i<=m;i++)
        {
            cin >> a[i] >> c[i];
            sum=sum+a[i];
        }
        float dp[sum+5];
        dp[0]=1;
        for(int i=1;i<=sum;i++)
            dp[i]=0;
        int ans=0;
        for(int i=1;i<=m;i++)
            for(int j=sum;j>=0;j--)
        {
            if(j-a[i]>=0)
                dp[j]=max(dp[j],dp[j-a[i]]-(dp[j-a[i]]*c[i]));
            else
                dp[j]=dp[j];
            if(dp[j]>1-p)
                ans=max(ans,j);
        }
        cout << ans << endl;
    }
    return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值