1151 LCA in a Binary Tree(30 分)

The lowest common ancestor (LCA) of two nodes U and V in a tree is the deepest node that has both U and V as descendants.

Given any two nodes in a binary tree, you are supposed to find their LCA.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 1,000), the number of pairs of nodes to be tested; and N (≤ 10,000), the number of keys in the binary tree, respectively. In each of the following two lines, N distinct integers are given as the inorder and preorder traversal sequences of the binary tree, respectively. It is guaranteed that the binary tree can be uniquely determined by the input sequences. Then M lines follow, each contains a pair of integer keys U and V. All the keys are in the range of int.

Output Specification:

For each given pair of U and V, print in a line LCA of U and V is A. if the LCA is found and A is the key. But if A is one of U and V, print X is an ancestor of Y. where X is A and Y is the other node. If U or V is not found in the binary tree, print in a line ERROR: U is not found. or ERROR: V is not found. or ERROR: U and V are not found..

Sample Input:

6 8
7 2 3 4 6 5 1 8
5 3 7 2 6 4 8 1
2 6
8 1
7 9
12 -3
0 8
99 99

Sample Output:

LCA of 2 and 6 is 3.
8 is an ancestor of 1.
ERROR: 9 is not found.
ERROR: 12 and -3 are not found.
ERROR: 0 is not found.
ERROR: 99 and 99 are not found.
给定一棵树的中序和前序遍历,要求查询两个点的最低祖先,需要记录高度。
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <map>
using namespace std;
struct tree
{
    int Data,Height;
    tree *Last,*Left,*Right;
}*head;
int q[10001],z[10001],m,n;
map<int,tree *> mp;///根据序号映射到结点
tree *createNode(int d,int h)///创建新结点并返回
{
    tree *p = new tree();
    p -> Data = d;
    mp[d] = p;
    p -> Height = h;
    p -> Last = p -> Left = p -> Right = NULL;
    return p;
}
tree *createTree(int ql,int qr,int zl,int zr,int h)///前中序 还原树
{
    tree *p = createNode(q[ql],h);
    for(int i = zl;i <= zr;i ++)
    {
        if(z[i] == q[ql])
        {
            if(i > zl)p -> Left = createTree(ql + 1,ql + i - zl,zl,i - 1,h + 1),p -> Left -> Last = p;
            if(i < zr)p -> Right = createTree(ql + i - zl + 1,qr,i + 1,zr,h + 1),p -> Right -> Last = p;
            break;
        }
    }
    return p;
}
void check(int a,int b)///判断两点
{
    if(mp[a] == NULL && mp[b] == NULL)printf("ERROR: %d and %d are not found.\n",a,b);
    else if(mp[a] == NULL)printf("ERROR: %d is not found.\n",a);
    else if(mp[b] == NULL)printf("ERROR: %d is not found.\n",b);
    else {
        tree *t1 = mp[a],*t2 = mp[b];
        while(t1 -> Height != t2 -> Height) {
            if(t1 -> Height > t2 -> Height)t1 = t1 -> Last;
            else t2 = t2 -> Last;
        }///调整至高度相同
        if(t1 == t2) {///一个点是另一个点的祖先
            printf("%d is an ancestor of %d.\n",t1 -> Data,a == t1 -> Data ? b : a);
            return;
        }while(t1 != t2) {
            t1 = t1 -> Last;
            t2 = t2 -> Last;
        }
        printf("LCA of %d and %d is %d.\n",a,b,t1 -> Data);
    }
}
int main() {
    int a,b;
    scanf("%d%d",&m,&n);
    for(int i = 0;i < n;i ++) {
        scanf("%d",&z[i]);
    }
    for(int i = 0;i < n;i ++) {
        scanf("%d",&q[i]);
    }
    head = createTree(0,n - 1,0,n - 1,0);
    for(int i = 0;i < m;i ++) {
        scanf("%d%d",&a,&b);
        check(a,b);
    }
}

 

转载于:https://www.cnblogs.com/8023spz/p/9619511.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值