HDU 1391:Number Steps

Number Steps

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4727    Accepted Submission(s): 2884


Problem Description
Starting from point (0,0) on a plane, we have written all non-negative integers 0, 1, 2,... as shown in the figure. For example, 1, 2, and 3 has been written at points (1,1), (2,0), and (3, 1) respectively and this pattern has continued.



You are to write a program that reads the coordinates of a point (x, y), and writes the number (if any) that has been written at that point. (x, y) coordinates in the input are in the range 0...5000.
 

Input
The first line of the input is N, the number of test cases for this problem. In each of the N following lines, there is x, and y representing the coordinates (x, y) of a point.
 

Output
For each point in the input, write the number written at that point or write No Number if there is none.
 

Sample Input
 
  
3 4 2 6 6 3 4
 

Sample Output
 
  
6 12 No Number
 

Source
 

Recommend
Ignatius.L   |   We have carefully selected several similar problems for you:   1106  1040  1209  1029  2673 
 

你  离  开  了  ,  我  的  世  界  里  只  剩  下  雨  。  。  。

#include<iostream>
using namespace std;
int main()
{
    int n;
    cin>>n;
    while(n--)
    {
        int a,b;
        cin>>a>>b;
        if(a==b||a-b==2)
        {
            if(a==b)
            {
                if(a&1)cout<<2*a-1<<endl;
                else cout<<2*a<<endl;
            }
            else
            {
                if(b&1)cout<<2*a-3<<endl;
                else cout<<2*a-2<<endl;
            }
        }
        else cout<<"No Number"<<endl;
    }
    return 0;
}

转载于:https://www.cnblogs.com/im0qianqian/p/5989574.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值