POJ 2524 并查集

Ubiquitous Religions
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 20197 Accepted: 9920

Description

There are so many different religions in the world today that it is difficult to keep track of them all. You are interested in finding out how many different religions students in your university believe in. 

You know that there are n students in your university (0 < n <= 50000). It is infeasible for you to ask every student their religious beliefs. Furthermore, many students are not comfortable expressing their beliefs. One way to avoid these problems is to ask m (0 <= m <= n(n-1)/2) pairs of students and ask them whether they believe in the same religion (e.g. they may know if they both attend the same church). From this data, you may not know what each person believes in, but you can get an idea of the upper bound of how many different religions can be possibly represented on campus. You may assume that each student subscribes to at most one religion.

Input

The input consists of a number of cases. Each case starts with a line specifying the integers n and m. The next m lines each consists of two integers i and j, specifying that students i and j believe in the same religion. The students are numbered 1 to n. The end of input is specified by a line in which n = m = 0.

Output

For each test case, print on a single line the case number (starting with 1) followed by the maximum number of different religions that the students in the university believe in.

Sample Input

10 9
1 2
1 3
1 4
1 5
1 6
1 7
1 8
1 9
1 10
10 4
2 3
4 5
4 8
5 8
0 0

Sample Output

Case 1: 1
Case 2: 7
这是一道水题,基本就直接套模板就行了,不需要被别的什么东西,尼玛,结果就这样一个破题,因为模板敲错了,结果就wa了半天,,最后被小bb一眼看出了错误,接着才过,下面是代码:
 
 
#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>

using namespace std;

const int maxn=10000000;
int pre[maxn];

int find(int v){
   return pre[v]==v?v:find(pre[v]);
}

void join(int a,int b){
     int f1=find(a),f2=find(b);
     if(f1!=f2)
       pre[f1]=f2;
}

int main(){
    int n,m;
    int count;
for(count=1;;count++){
    cin>>n>>m;
    if(n==0&&m==0)
       break;
    for(int i=1;i<=n;i++){
          pre[i]=i;
    }
    int max=n;
    for(int i=1;i<=m;i++){
          int a,b;
          cin>>a>>b;
          if(find(a)!=find(b))
              max=max-1;
          join(a,b);
     }
      printf("Case %d: ",count);
      printf("%d\n",max);
}
    return 0;
}


转载于:https://www.cnblogs.com/dyllove98/p/3217800.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值