PKU OJ Exponentiation

Exponentiation
Time Limit: 500MS                      Memory Limit: 10000K
Total Submissions: 155886        Accepted: 37967

Description

Problems involving the computation of exact values of very large magnitude and precision are common. For example, the computation of the national debt is a taxing experience for many computer systems.

This problem requires that you write a program to compute the exact value of Rn where R is a real number ( 0.0 < R < 99.999 ) and n is an integer such that 0 < n <= 25.

Input

The input will consist of a set of pairs of values for R and n. The R value will occupy columns 1 through 6, and the n value will be in columns 8 and 9.

Output

The output will consist of one line for each line of input giving the exact value of R^n. Leading zeros should be suppressed in the output. Insignificant trailing zeros must not be printed. Don't print the decimal point if the result is an integer.
Sample Input

95.123 12
0.4321 20
5.1234 15
6.7592  9
98.999 10
1.0100 12

Sample Output

548815620517731830194541.899025343415715973535967221869852721
.00000005148554641076956121994511276767154838481760200726351203835429763013462401
43992025569.928573701266488041146654993318703707511666295476720493953024
29448126.764121021618164430206909037173276672
90429072743629540498.107596019456651774561044010001
1.126825030131969720661201

Hint

If you don't know how to determine wheather encounted the end of input:
s is a string and n is an integer

难度不算很大,主要是这种高精度的运算不能直接用语言里面的运算符,要从计算的本质出发,用数组加上乘法进位的思想

另外一个是小数点标在哪儿的问题,我处理的时候直接记录每个数应该是有多少位小数点,然后只做整数的乘法,最后算完了才来标小数点。

下面的应该是AC的。

#include <iostream>
using namespace std;

class Problem {
	char a[10];				//获取字符串
	int R[130];		//5位数的25次方,最多只有125位
	int tmp_R[130];
	int unvar_R[5];
	static short int n;		//指数
	short int m;			//小数位
public:
	Problem() {
		for(int i=0; i<130; i++) {
			R[i]=0;
			tmp_R[i]=0;
		}
	}
	void getString() {
		cin.getline(a,10);
	}
	void printString() {
		cout << "题目给出的字符串为: ";
		cout << a << endl;
		cout << "所求问题的指数为: ";
		cout << n << endl;
		cout << "底数的小数位为: ";
		cout << m << endl;
		cout << "底数的整数形式为: ";
		for (int i=5; i>=1; i--) {
			cout << R[130-i] << " ";
		}
		cout << endl;
		cout << "不变的乘数: ";
		for (int i=5; i>=1; i--) {
			cout << unvar_R[5-i] << " ";
		}
		cout << endl;
	}
	void allocateValue(char* s, int upper) {
		for(int i=0; i<6; i++)
			a[i] = s[i];
		short int i=10, j=1;
		//获取指数n
		while(a[i-2] != ' ') {
			n += (a[i-2]-48) * j;
			j *= 10;
			i--;
		}	
		n = upper;
		i=5;
		//获取小数位数
		j=0;
		for(i=5; i>=0; i--) {
			if(a[i] != '.')
				j++;
			else
				break;
		}
		m = j;
		j=1;
		//获得整数段
		for (i=5; i>=0; i--) {
			if(a[i] == '.')
				continue;
			else {
				R[130-j]=a[i]-48;
				unvar_R[5-j]=a[i]-48;
				j++;
			}
		}
	}
	//两个整数相乘
	void Product() {
		int temp;
		int pos;
		//给tmp_R一个初始数据
		for(int i=0; i<5; i++)
			tmp_R[129-i] = unvar_R[4-i];
		//相当于乘unvar_R n-1次
		for(int k=1; k<n; k++) {
			for(int i=0; i<130; i++)
				R[i] = 0;
			for(int i=0; i<5; i++) {
				for(int j=0; j<125; j++) {
					pos=129-i-j;
					R[pos] += unvar_R[4-i]*tmp_R[129-j];
				}
			}
			for(int i=129; i>=1; i--) {
				temp = R[i];
				R[i] = temp%10;
				tmp_R[i] = R[i];
				R[i-1] += temp/10;
			}
		}
	}

	void printResult() {
		int head=0, tail=0;
		//前面部分0的个数
		for(int i=0; i<130; i++) {
			if( R[i] == 0 )
				head = head+1;
			else
				break;
		}
		//后面部分0的个数
		for(int i=130; i>=1; i--) {
			if( R[i-1] == 0 )
				tail = tail+1;
			else
				break;
		}
		int dotpos;
		dotpos = m*n;		//小数位应该有的位数

		if(head==130) {
			cout << "0";
			cout << endl;
			return;
		}

		if(tail>=dotpos){	//小数点的位数小于尾部0的个数,则为整数
			for (int i=head; i<130-dotpos; i++)
				cout << R[i];	
		}
		else if(head>=130-dotpos){		//小数的整数部分为0
			cout << ".";
			for(int i=130-dotpos; i<130-tail; i++)
				cout << R[i];
		}
		else{				//整数部分不为0,小数部分不为0
			for(int i=head; i<130-dotpos; i++)
				cout << R[i];
			cout << ".";
			for(int i=130-dotpos; i<130-tail; i++)
				cout << R[i];
		}	
		cout << endl;
		return;
	}
	void init(){
		for(int i=0; i<130; i++) {
			R[i] = 0;
			tmp_R[i] = 0;
		}
		for(int i=0; i<5; i++)
			unvar_R[i] = 0;
		m=0;
		n=0;
	}
					
};

short int Problem::n=0;

int main(void) {
	Problem a;
	char s[6];
	int n;
	while(cin>>s>>n) {
		a.getString();
		a.allocateValue(s,n);
		//a.printString();
		a.Product();
		a.printResult();
		a.init();
	}
	return 0;
}	

转载于:https://www.cnblogs.com/tuhooo/p/5441425.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值