ZOJ 3609 Modular Inverse

Modular Inverse
Time Limit: 2 Seconds Memory Limit: 65536 KB
The modular modular multiplicative inverse of an integer a modulo m is an integer x such that a-1≡x (mod m). This is equivalent to ax≡1 (mod m).

Input

There are multiple test cases. The first line of input is an integer T ≈ 2000 indicating the number of test cases.

Each test case contains two integers 0 < a ≤ 1000 and 0 < m ≤ 1000.

Output

For each test case, output the smallest positive x. If such x doesn’t exist, output “Not Exist”.

Sample Input

3
3 11
4 12
5 13
Sample Output

4
Not Exist
8

#include <iostream>
#include <string.h>
#include <stdio.h>
#include <math.h>
#include <stdlib.h>
#include <algorithm>

using namespace std;
int a,m;
int tag[1005];
int ans;
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&a,&m);
        int x=1;
        bool flag=true;
        memset(tag,0,sizeof(tag));
        while(1)
        {
            if(((a*x)%m)==(1%m))
            {ans=x;break;}
            else
            {
                x++;
                int num=(a*x)%m;
                if(tag[num])
                {
                    flag=false;
                    break;
                }
                tag[num]=1;

            }
        }
        if(!flag)
            printf("Not Exist\n");
        else
            printf("%d\n",ans);
    }
    return 0;
}

转载于:https://www.cnblogs.com/dacc123/p/8228707.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值