(扩展欧几里得)Modular Inverse--Zoj

Modular Inverse

Time Limit: 2 Seconds      Memory Limit: 65536 KB

The modular modular multiplicative inverse of an integer a modulo m is an integer x such that a-1x (mod m). This is equivalent to ax≡1 (mod m).

Input

There are multiple test cases. The first line of input is an integer T ≈ 2000 indicating the number of test cases.

Each test case contains two integers 0 < a ≤ 1000 and 0 < m ≤ 1000.

Output

For each test case, output the smallest positive x. If such x doesn't exist, output "Not Exist".

Sample Input
3
3 11
4 12
5 13
Sample Output
4
Not Exist
8



总结:

称之为 x 是关于 m 的乘法逆元,等价于 ax + my = 1 当1 对 gcd(a,m)取余不等于零时,则无解

/*
    a*x
*/
#include<iostream>
#include<string>
#include<algorithm>
#include<set>
#include<queue>
#include<vector>
#include<math.h>
#include<string.h>
#include<stdio.h>
#define LL long long
using namespace std;

//扩展欧几里得模板
LL e_gcd(LL a,LL b,LL &x,LL &y)
{
    if(b==0)
    {
        x=1;
        y=0;
        return a;
    }
    LL ans=e_gcd(b,a%b,x,y);
    LL temp=x;
    x=y;
    y=temp-a/b*y;
    return ans;
}
//扩展欧几里得模板
LL Cal(LL a,LL b,LL c)
{
    LL x,y;
    LL gcd=e_gcd(a,b,x,y);
    if(c%gcd!=0) return -1;
    x*=c/gcd;
    b/=gcd;
    if(b<0) b=-b;
    LL ans=x%b;
    if(ans<=0) ans+=b;
    return ans;
}

int main(void)
{
    int ncase;
    cin >> ncase;
    while(ncase--)
    {
        LL a,m,ans;
        scanf("%lld %lld",&a,&m);
        ans = Cal(a,m,1);//等价于 ax + by = 1
        if(ans==-1) printf("Not Exist\n");//如果1 对 gcd(a,b)取余不等于零,则无解
        else printf("%lld\n",ans);
    }


	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值