hdu5305 Friends

Problem Description
There are  n people and  m pairs of friends. For every pair of friends, they can choose to become online friends (communicating using online applications) or offline friends (mostly using face-to-face communication). However, everyone in these  n people wants to have the same number of online and offline friends (i.e. If one person has  x onine friends, he or she must have  x offline friends too, but different people can have different number of online or offline friends). Please determine how many ways there are to satisfy their requirements. 
 

Input
The first line of the input is a single integer  T (T=100), indicating the number of testcases. 

For each testcase, the first line contains two integers  n (1n8) and  m (0mn(n1)2), indicating the number of people and the number of pairs of friends, respectively. Each of the next  m lines contains two numbers  x and  y, which mean  x and  y are friends. It is guaranteed that  xy and every friend relationship will appear at most once. 
 

Output
For each testcase, print one number indicating the answer.
 

Sample Input
 
  
2 3 3 1 2 2 3 3 1 4 4 1 2 2 3 3 4 4 1
 

Sample Output
 
  
0

2

这题是一道简单搜索题,我用dfs(idx,num1,num2)表示当前搜索的是idx的关系,num1表示虚拟关系的个数,num2表示现实关系的个数。

#include<iostream>
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<math.h>
#include<vector>
#include<map>
#include<set>
#include<queue>
#include<stack>
#include<string>
#include<algorithm>
using namespace std;
#define maxn 100060
#define ll long long
int num[10],gra[10][10],n,m,sum,guanxi[10][10],vis1[10],vis2[10];

void dfs(int idx,int num1,int num2,int pos,int from)
{
    int i,j;
    if(num1==num2 && num1+num2==num[idx]){
        if(idx==n){
            sum++;return;
        }
        else{
            idx++;num1=num2=0;
            for(i=1;i<=n;i++){
               if(guanxi[idx][i]==1){
                   num2++;
               }
               else if(guanxi[idx][i]==0){
                   num1++;
               }
            }
            dfs(idx,num1,num2,idx+1,0);
        }
        return ;
    }

    if(num1>num[idx]/2 || num2>num[idx]/2)return;
    for(i=pos;i<=n;i++){
        if(gra[i][idx] && guanxi[i][idx]==-1){
            guanxi[i][idx]=guanxi[idx][i]=0;
            dfs(idx,num1+1,num2,i+1,1);
            guanxi[i][idx]=guanxi[idx][i]=1;
            dfs(idx,num1,num2+1,i+1,2);
            guanxi[i][idx]=guanxi[idx][i]=-1;break;
        }
    }
    return;
}

int main()
{
        int i,j,T,c,d,flag;
        scanf("%d",&T);
        while(T--)
        {
            scanf("%d%d",&n,&m);
            if(n==1){
                printf("1\n");continue;
            }
            memset(num,0,sizeof(num));
            memset(gra,0,sizeof(gra));
            for(i=1;i<=m;i++){
                scanf("%d%d",&c,&d);
                gra[c][d]=gra[d][c]=1;num[c]++;num[d]++;
            }
            flag=1;
            for(i=1;i<=n;i++){
                if(num[i]&1){
                    flag=0;break;
                }
            }
            if(!flag){
                printf("0\n");continue;
            }
            sum=0;
            memset(guanxi,-1,sizeof(guanxi));
            dfs(1,0,0,2,0);
            printf("%d\n",sum);
        }
        return 0;
}


转载于:https://www.cnblogs.com/herumw/p/9464686.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值