hdu 5305

Friends

Problem Description
There are  n  people and  m  pairs of friends. For every pair of friends, they can choose to become online friends (communicating using online applications) or offline friends (mostly using face-to-face communication). However, everyone in these  n  people wants to have the same number of online and offline friends (i.e. If one person has  x  onine friends, he or she must have  x  offline friends too, but different people can have different number of online or offline friends). Please determine how many ways there are to satisfy their requirements. 
 

Input
The first line of the input is a single integer  T (T=100) , indicating the number of testcases. 

For each testcase, the first line contains two integers  n (1n8)  and  m (0mn(n1)2) , indicating the number of people and the number of pairs of friends, respectively. Each of the next  m  lines contains two numbers  x  and  y , which mean  x  and  y  are friends. It is guaranteed that  xy  and every friend relationship will appear at most once. 
 

Output
For each testcase, print one number indicating the answer.
 

Sample Input
  
  
2 3 3 1 2 2 3 3 1 4 4 1 2 2 3 3 4 4 1
 

Sample Output
  
  
0 2
 
 
dfs遍历边,入手点很重要。
代码如下:
#include<stdio.h>
#include<iostream>
#include<string.h>
using namespace std;
int x[50],y[50],index[50],on[50],off[50],ans,m,n;
void dfs(int num)
{
    if(num==m+1){
        for(int i=1;i<=n;i++)
            if(on[i]!=off[i])
                return ;
        ans++;
        return ;
    }
    int a=x[num],b=y[num];
    if(on[a]<index[a]/2&&on[b]<index[b]/2){
        on[a]++;
        on[b]++;
        dfs(num+1);
        on[a]--;
        on[b]--;
    }
    if(off[a]<index[a]/2&&off[b]<index[b]/2){
        off[a]++;
        off[b]++;
        dfs(num+1);
        off[a]--;
        off[b]--;
    }
    return ;
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--){
        scanf("%d%d",&n,&m);
        memset(index,0,sizeof(index));
        memset(on,0,sizeof(on));
        memset(off,0,sizeof(off));
        for(int i=1;i<=m;i++){
            scanf("%d%d",&x[i],&y[i]);
            index[x[i]]++;
            index[y[i]]++;
        }
        ans=0;
        dfs(1);
        printf("%d\n",ans);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值