Sum

A square-free integer is an integer which is indivisible by any square number except 11. For example, 6 = 2 \cdot 36=23 is square-free, but 12 = 2^2 \cdot 312=223 is not, because 2^222 is a square number. Some integers could be decomposed into product of two square-free integers, there may be more than one decomposition ways. For example, 6 = 1\cdot 6=6 \cdot 1=2\cdot 3=3\cdot 2, n=ab6=16=61=23=32,n=ab and n=ban=ba are considered different if a \not = ba=b. f(n)f(n) is the number of decomposition ways that n=abn=ab such that aaand bb are square-free integers. The problem is calculating \sum_{i = 1}^nf(i)i=1nf(i).

Input

The first line contains an integer T(T\le 20)T(T20), denoting the number of test cases.

For each test case, there first line has a integer n(n \le 2\cdot 10^7)n(n2107).

Output

For each test case, print the answer \sum_{i = 1}^n f(i)i=1nf(i).

Hint

\sum_{i = 1}^8 f(i)=f(1)+ \cdots +f(8)i=18f(i)=f(1)++f(8)
=1+2+2+1+2+4+2+0=14=1+2+2+1+2+4+2+0=14.

样例输入复制
2
5
8
样例输出复制
8
14
题目来源

ACM-ICPC 2018 南京赛区网络预赛

 

欧拉筛法学习。

代码:

#include <iostream>
#define MAX 10000000
using namespace std;
int t;
int n;
int num[MAX * 2 + 1],sum[MAX * 2 + 1];
bool vis[MAX * 2 + 1];
int prime[MAX + 1];
void init() {
    sum[1] = num[1] = 1;
    for(int i = 2;i <= MAX * 2;i ++) {
        if(!vis[i]) {
            prime[++ prime[0]] = i;
            num[i] = 2;
        }
        for(int j = 1;j <= prime[0] && i * prime[j] <= MAX * 2;j ++) {
            vis[i * prime[j]] = true;
            if(i % prime[j] == 0) {
                if(i / prime[j] % prime[j]) num[i * prime[j]] = num[i / prime[j]];
                break;
            }
            num[i * prime[j]] = num[i] * num[prime[j]];
        }
        sum[i] += sum[i - 1] + num[i];
    }
}
int main() {
    scanf("%d",&t);
    init();
    while(t --) {
        scanf("%d",&n);
        printf("%d\n",sum[n]);
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/8023spz/p/10757525.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值