hdu-5578 Friendship of Frog(暴力)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5578

Friendship of Frog

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 556    Accepted Submission(s): 355


Problem Description
N frogs from different countries are standing in a line. Each country is represented by a lowercase letter. The distance between adjacent frogs (e.g. the 1st and the 2nd frog, the N1th and the Nth frog, etc) are exactly 1. Two frogs are friends if they come from the same country.

The closest friends are a pair of friends with the minimum distance. Help us find that distance.
 

 

Input
First line contains an integer  T, which indicates the number of test cases.

Every test case only contains a string with length N, and the ith character of the string indicates the country of ith frogs.

 1T50.

 for 80% data, 1N100.

 for 100% data, 1N1000.

 the string only contains lowercase letters.
 

 

Output
For every test case, you should output " Case #x: y", where  x indicates the case number and counts from 1 and y is the result. If there are no frogs in same country, output 1 instead.
 

 

Sample Input
2 abcecba abc
 

 

Sample Output
Case #1: 2
Case #2: -1
AC代码:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
char str[1009];
int main()
{
    int t;
    scanf("%d",&t);
    int cnt=1;
    while(t--)
    {
        scanf("%s",str);
        int len=strlen(str);
        int ans=20000,flag=0;
        for(int i=0;i<len;i++)
        {
            for(int j=i+1;j<len;j++)
            {
                if(str[j]==str[i])
                {
                    ans=min(ans,j-i);
                    flag=1;
                    break;
                }
            }
        }
        if(!flag)ans=-1;
        printf("Case #%d: %d\n",cnt++,ans);
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/zhangchengc919/p/5260119.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值