POJ 2407 Relatives(欧拉函数入门题)

Relatives

Given n, a positive integer, how many positive integers less than n are relatively prime to n? Two integers a and b are relatively prime if there are no integers x > 1, y > 0, z > 0 such that a = xy and b = xz.

Input

There are several test cases. For each test case, standard input contains a line with n <= 1,000,000,000. A line containing 0 follows the last case.

Output

For each test case there should be single line of output answering the question posed above.
 
Sample Input
7
12
0
Sample Output
6
4

题意:输入个n,求(1,n-1)与n互质的个数有多少个
思路:这明显就是欧拉函数模版题,就是求n的欧拉数
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
typedef long long ll;
ll phi(ll n)//求n的欧拉数
{
    ll sum=n;
    for(int i=2;i*i<=n;i++)//O(根号n的复杂度)
    {
        if(n%i==0)
        {
            sum=sum-sum/i;
            do
            {
                n/=i;
            }while(n%i==0);
        }
    }
    if(n>1) sum=sum-sum/n;
    return sum;
}
int main()
{
    ll n;
    while(scanf("%lld",&n)!=EOF)
    {
        if(n==0)
        break;
        printf("%lld\n",phi(n));
    }
}

 

 

转载于:https://www.cnblogs.com/Lis-/p/9387619.html

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值