Relatives
Time Limit:1000MS Memory Limit:65536KB 64bit IO Format:%lld & %llu
Description
Given n, a positive integer, how many positive integers less than n are relatively prime to n? Two integers a and b are relatively prime if there are no integers x > 1, y > 0, z > 0 such that a = xy and b = xz.
Input
There are several test cases. For each test case, standard input contains a line with n <= 1,000,000,000. A line containing 0 follows the last case.
Output
For each test case there should be single line of output answering the question posed above.
Sample Input
7
12
0
Sample Output
6
4
题意:求[1,N]内与N互质的个数,N达到10^9;
思路:N太大,不能用素数筛(O(N))的方法, 一个一个求就行了,根据算数定理将N分解质因数,不断缩小知道1或素数为止,在这个过程中求出欧拉;
失误:学习(不懂的还很多呢)。
AC代码:
#include<cstdio>
int Euler(int N)
{
int eu=N,i=0;
for(i=2;i*i<=N;++i)
{
if(N%i==0)
{
eu=eu/i*(i-1);
while(N%i==0) N/=i;
}
}
if(N>1) eu=eu/N*(N-1);
return eu;
}
int main()
{
int N;
while(scanf("%d",&N),N)
{
printf("%d\n",Euler(N));
}
return 0;
}