uva10375(唯一分解定理) Choose and divide


The binomial coefficient C(m, n) is defined as

                                                               C(m, n) = m!(m − n)! n!

Given four natural numbers p, q, r, and s, compute the the result of dividing C(p, q) by C(r, s).

Input

       Input consists of a sequence of lines. Each line contains four non-negative integer numbers giving valuesfor p, q, r, and s, respectively, separated by a single space. All the numbers will be smaller than 10,000with p ≥ q and r ≥ s.


Output

For each line of input, print a single line containing a real number with 5 digits of precision in the fraction,giving the number as described above. You may assume the result is not greater than 100,000,000.


Sample Input


10 5 14 9

93 45 84 59

145 95 143 92

995 487 996 488

2000 1000 1999 999

9998 4999 9996 4998


Sample Output

0.12587

505606.46055

1.28223

0.48996

2.00000

3.99960


#include <stdio.h>
#include <string.h>
#include <math.h>
#include<algorithm>
using namespace std;
#define MAXN 12000
int prime[MAXN+1];
int len;
void getPrime()
{
    int m=sqrt(MAXN+0.5);
    memset(prime,0,sizeof(prime));
    for(int i=2; i<=m; i++)
        if(!prime[i])
        {
            for(int j=i*i; j<=MAXN; j+=i)
                prime[j]=1;
        }

    len=0;
    for(int i=2; i<=MAXN; ++i)
    {
        if(!prime[i])
            prime[len++]=i;
    }
}
int e[MAXN+1];
void add_integer(int n,int d)
{
    for(int i=0; i<len; i++)
    {
        while(n%prime[i]==0)
        {
            n/=prime[i];
            e[i]+=d;//记录指数
        }
        if(n==1) break;
    }
}
void add_factorial(int n,int d)
{
    for(int i=1; i<=n; i++)//n的阶乘
        add_integer(i,d);//求素数表示
}
int main()
{
    getPrime();
    int p,q,r,s;
    while(scanf("%d%d%d%d",&p,&q,&r,&s)!=EOF)
    {
        memset(e,0,sizeof(e));
        add_factorial(p,1);//1  分子
        add_factorial(q,-1);//-1 分母
        add_factorial(p-q,-1);
        add_factorial(r,-1);
        add_factorial(s,1);
        add_factorial(r-s,1);
        int maxn=max(p,r);
        double ans=1;
        for(int i=0; i<=maxn; i++)
        {
            ans*=pow(prime[i],e[i]); //啦啦
        }
        printf("%.5lf\n",ans);
    }
    return 0;
}


转载于:https://www.cnblogs.com/zitian246/p/9123602.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值