POJ 1738 An old Stone Game(石子合并 经典)

An old Stone Game
Time Limit: 5000MS Memory Limit: 30000K
Total Submissions: 3672 Accepted: 1035

Description

There is an old stone game.At the beginning of the game the player picks n(1<=n<=50000) piles of stones in a line. The goal is to merge the stones in one pile observing the following rules:
At each step of the game,the player can merge two adjoining piles to a new pile.The score is the number of stones in the new pile.
You are to write a program to determine the minimum of the total score.

Input

The input contains several test cases. The first line of each test case contains an integer n, denoting the number of piles. The following n integers describe the number of stones in each pile at the beginning of the game.
The last test case is followed by one zero.

Output

For each test case output the answer on a single line.You may assume the answer will not exceed 1000000000.

Sample Input

1
100
3
3 4 3
4
1 1 1 1
0

Sample Output

0
17
8
#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>
#include <vector>
#include <cstdlib>
#include <iomanip>
#include <cmath>
#include <ctime>
#include <map>
#include <set>
using namespace std;
#define lowbit(x) (x&(-x))
#define max(x,y) (x>y?x:y)
#define min(x,y) (x<y?x:y)
#define MAX 100000000000000000
#define MOD 1000000007
#define pi acos(-1.0)
#define ei exp(1)
#define PI 3.141592653589793238462
#define INF 0x3f3f3f3f3f
#define mem(a) (memset(a,0,sizeof(a)))
typedef long long ll;
ll a[50006],ans,n,pos;
void check(int x)
{
    int i,j;
    int mx=a[x]+a[x-1];
    ans+=mx;
    for(i=x;i<pos-1;i++)
        a[i]=a[i+1];
    pos--;
    for(j=x-1;j>0 && a[j-1]<mx;j--)
        a[j]=a[j-1];
    a[j]=mx;
    while(j>=2 && a[j-2]<=a[j])
    {
        int y=pos-j;//j后面有多少个数,往前移;
        check(j-1);
        j=pos-y;
    }
}
int main()
{
    while(scanf("%lld",&n)&& n)
    {
        for(int i=0;i<n;i++)
        {
            scanf("%lld",&a[i]);
        }
        pos=1;ans=0;
        for(int i=1;i<n;i++)
        {
            a[pos++]=a[i];
            while(pos>=3 && a[pos-3]<=a[pos-1])
            {
                check(pos-2);
            }
        }
        while(pos>1) check(pos-1);
        printf("%lld\n",ans);
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/shinianhuanniyijuhaojiubujian/p/7239471.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值