HDU 4006 The kth great number

 

Problem Description
Xiao Ming and Xiao Bao are playing a simple Numbers game. In a round Xiao Ming can choose to write down a number, or ask Xiao Bao what the kth great number is. Because the number written by Xiao Ming is too much, Xiao Bao is feeling giddy. Now, try to help Xiao Bao.
 

 

Input
There are several test cases. For each test case, the first line of input contains two positive integer n, k. Then n lines follow. If Xiao Ming choose to write down a number, there will be an " I" followed by a number that Xiao Ming will write down. If Xiao Ming choose to ask Xiao Bao, there will be a "Q", then you need to output the kth great number.
 

 

Output
The output consists of one integer representing the largest number of islands that all lie on one line.
 

 

Sample Input
8 3 I 1 I 2 I 3 Q I 5 Q I 4 Q
 

 

Sample Output
1 2 3
Hint
Xiao Ming won't ask Xiao Bao the kth great number when the number of the written number is smaller than k. (1=<k<=n<=1000000).
 

 

Source
 

 

题意:求第K大的数
昨天学术节比赛,这是最后一题,给我们大一做的题目都比这难点,唉!打击了、要奋斗了!
这题昨天用堆来做,建立K个元素的堆、再更新,维护堆,今早用STL优先队列做,STL是个好东西
 

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>
#define N 1000003
using namespace std;
int hp[N];
void ct(int n)//堆的建立
{
    while(n>1)
        if(hp[n]<hp[n/2])
        {
            swap(hp[n],hp[n/2]);
            n=n/2;
        }
        else
            break;        
}
void wh(int k)//堆的维护
{
     int i=1,min;
     while((i*2)<=k)
     {
       if(i*2+1<=k)
       {
           if(hp[i<<1]>hp[i<<1|1])
             min=i<<1|1;
         else
             min=i<<1;
       }
       else
           min=i<<1;

         if(hp[i]>hp[min])
         {
             swap(hp[i],hp[min]);
             i=min;
         }
         else
             break;
     }

}
int main()
{
    int i,n,k,j,l,up;
    char c;
   while(scanf("%d%d",&n,&k)!=EOF)
   {   
         getchar();
         scanf("%c%d",&c,&up);
         getchar();
         hp[1]=up;l=2;
         for(i=1;i<k;i++)
         {
             scanf("%c%d",&c,&up); getchar();
             hp[l]=up;
             ct(l);l++;
         }
             for(;i<n;i++)
         {
            scanf("%c",&c);
            if(c=='Q')
            {
               printf("%d\n",hp[1]);
            }
            else
            {
              scanf("%d",&up);
              if(up>hp[1])
              {
                  hp[1]=up;
                  wh(k);
              }
            }
            getchar();
         }
  
   }
    return 0;
}


#include<iostream>
#include<cstdio>
#include<queue>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
int main()
{  
    int i,n,k,ad;
    char c;
    while(scanf("%d%d",&n,&k)!=EOF)
    {   priority_queue< int,vector<int>,greater<int> > pq;
         getchar();
        for(i=0;i<k;i++)
         {
             scanf("%c%d",&c,&ad);
             pq.push(ad);getchar();
         }
        for(;i<n;i++)
        {
            scanf("%c",&c);
            if(c=='Q')
              printf("%d\n",pq.top());
            else
            {
                scanf("%d",&ad);
                if(ad>pq.top())
                   {
                       pq.pop();
                       pq.push(ad);
                   }
            }
            getchar();
        }
    }
}

转载于:https://www.cnblogs.com/372465774y/archive/2012/04/13/2445163.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
基于LSTM的财务因子预测选股模型LSTM (Long Short-Term Memory) 是一种特殊的循环神经网络(RNN)架构,用于处理具有长期依赖关系的序列数据。传统的RNN在处理长序列时往往会遇到梯度消失或梯度爆炸的问题,导致无法有效地捕捉长期依赖。LSTM通过引入门控机制(Gating Mechanism)和记忆单元(Memory Cell)来克服这些问题。 以下是LSTM的基本结构和主要组件: 记忆单元(Memory Cell):记忆单元是LSTM的核心,用于存储长期信息。它像一个传送带一样,在整个链上运行,只有一些小的线性交互。信息很容易地在其上保持不变。 输入门(Input Gate):输入门决定了哪些新的信息会被加入到记忆单元中。它由当前时刻的输入和上一时刻的隐藏状态共同决定。 遗忘门(Forget Gate):遗忘门决定了哪些信息会从记忆单元中被丢弃或遗忘。它也由当前时刻的输入和上一时刻的隐藏状态共同决定。 输出门(Output Gate):输出门决定了哪些信息会从记忆单元中输出到当前时刻的隐藏状态中。同样地,它也由当前时刻的输入和上一时刻的隐藏状态共同决定。 LSTM的计算过程可以大致描述为: 通过遗忘门决定从记忆单元中丢弃哪些信息。 通过输入门决定哪些新的信息会被加入到记忆单元中。 更新记忆单元的状态。 通过输出门决定哪些信息会从记忆单元中输出到当前时刻的隐藏状态中。 由于LSTM能够有效地处理长期依赖关系,它在许多序列建模任务中都取得了很好的效果,如语音识别、文本生成、机器翻译、时序预测等。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值