PAT 1040. Longest Symmetric String

Given a string, you are supposed to output the length of the longest symmetric sub-string. For example, given "Is PAT&TAP symmetric?", the longest symmetric sub-string is "s PAT&TAP s", hence you must output 11.

Input Specification:

Each input file contains one test case which gives a non-empty string of length no more than 1000.

Output Specification:

For each test case, simply print the maximum length in a line.

Sample Input:

Is PAT&TAP symmetric?

Sample Output:

11

分析
本题不难,在遍历时可以压缩一下

#include<iostream>
using namespace std;
string s;
bool issymmetric(int i,int j){
    while(i!=j){
        if(s[i]!=s[j]) return false;
        if(j-i==1) break; //如果是偶数对称的话
                i++; j--;
    }
    return true;
}
int main(){
    getline(cin,s);
    int max_len=1;
    for(int i=0;i<s.size()-max_len;i++){
        char c=s[i];
        for(int j=s.size();j>i+max_len-1;j--){
            if(s[j]==c&&issymmetric(i,j)==true){
               max_len=j-i+1>max_len?j-i+1:max_len; 
        }   
       }
    } 
    cout<<max_len<<endl;
    return 0;
}

转载于:https://www.cnblogs.com/A-Little-Nut/p/8305057.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值