素数回文数的个数

素数回文数的个数

题目描述

11 11 11 n n n 之间(包括 n n n),既是素数又是回文数的整数有多少个。

输入格式

一个大于 11 11 11 小于 10000 10000 10000 的整数 n n n

输出格式

11 11 11 n n n 之间的素数回文数个数。

样例 #1

样例输入 #1

23

样例输出 #1

1

提示

回文数指左右对称的数,如: 11 11 11 12121 12121 12121

// #include <iostream>
// #include <algorithm>
// #include <cstring>
// #include <sstream>//整型转字符串
// #include <stack>//栈
// #include <deque>//堆/优先队列
// #include <queue>//队列
// #include <map>//映射
// #include <unordered_map>//哈希表
// #include <vector>//容器,存数组的数,表数组的长度
#include <bits/stdc++.h>
using namespace std;

typedef long long ll;

bool check(ll x)
{
    for(ll i=2;i*i<=x;i++)
    { 
        if(x%i==0)
            return 0;
    }
    
    return 1;
}

ll find(ll x)
{
    string a,b;
    a=to_string(x);
    b=a;

    reverse(a.begin(),a.end());
    if(a==b) return 1;

    return 0;
}

int main()
{
    ll n;
    cin>>n;

    ll ans=0;
    for(ll i=11;i<=n;i++)
    {
        if(check(i)&&find(i)) ans++;
    }
    
    cout<<ans<<endl;
    return 0;
}
  • 5
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Pretty Boy Fox

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值