hdu5355 Cake

Problem Description
There are  m soda and today is their birthday. The  1-st soda has prepared  n cakes with size  1,2,,n. Now  1-st soda wants to divide the cakes into  m parts so that the total size of each part is equal. 

Note that you cannot divide a whole cake into small pieces that is each cake must be complete in the  m parts. Each cake must belong to exact one of  m parts.
 

Input
There are multiple test cases. The first line of input contains an integer  T, indicating the number of test cases. For each test case:

The first contains two integers  n and  m  (1n105,2m10), the number of cakes and the number of soda.
It is guaranteed that the total number of soda in the input doesn’t exceed 1000000. The number of test cases in the input doesn’t exceed 1000.
 

Output
For each test case, output "YES" (without the quotes) if it is possible, otherwise output "NO" in the first line.

If it is possible, then output  m lines denoting the  m parts. The first number  si of  i-th line is the number of cakes in  i-th part. Then  si numbers follow denoting the size of cakes in  i-th part. If there are multiple solutions, print any of them.
 

Sample Input
 
  
4 1 2 5 3 5 2 9 3
 

Sample Output
 
  
NO YES 1 5 2 1 4 2 2 3 NO YES 3 1 5 9 3 2 6 7

3 3 4 8

这题和木棒拼接正方形很像,用相同的思路就行了。

这里注意dfs可能比较深,所以要手动开栈。#pragma comment(linker, "/STACK:102400000,102400000") 这句话加在程序最前面。

#pragma comment(linker, "/STACK:102400000,102400000")
#include<iostream>
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<math.h>
#include<vector>
#include<map>
#include<set>
#include<queue>
#include<stack>
#include<string>
#include<algorithm>
using namespace std;
#define maxn 100050
#define ll long long
int vis[maxn],liang,fen,n;
set<int>myset[20];
set<int>::iterator it;

int dfs(int x,int pos,ll len)
{
	int i;
	if(x==fen)return 1;
	for(i=pos;i>=1;i--){
		if(!vis[i]){
			vis[i]=1;
			if(len+i<liang){
				myset[x].insert(i);
				if(dfs(x,i-1,len+i))return 1;
				myset[x].erase(i);
			}
			else if(len+i==liang){
				myset[x].insert(i);
				if(dfs(x+1,n,0))return 1;
				myset[x].insert(i);
			}
			vis[i]=0;
		}
	}
	return 0;
}


int main()
{
	int i,j,T;
	ll num;
	scanf("%d",&T);
	while(T--)
	{
		scanf("%d%d",&n,&fen);
		num=(ll)(n+1)*n/2;
		if(n<fen || num%fen!=0 || num/fen<n){
			printf("NO\n");continue;
		}
		liang=num/fen;
		memset(vis,0,sizeof(vis));
		for(i=0;i<=fen;i++){
			myset[i].clear();
		}
		
		if(dfs(0,n,0)){
			printf("YES\n");
			for(i=0;i<fen;i++){
				printf("%d",myset[i].size());
				for(it=myset[i].begin();it!=myset[i].end();it++){
					printf(" %d",*it);
				}
				printf("\n");
			}
		}
		else printf("NO\n");
	}
	return 0;
}
/*
100
50 10
NO
40 10
YES
3 3 39 40
3 7 37 38
3 11 35 36
3 15 33 34
3 19 31 32
3 23 29 30
4 1 26 27 28
5 2 9 22 24 25
5 6 17 18 20 21
8 4 5 8 10 12 13 14 16
*/



转载于:https://www.cnblogs.com/herumw/p/9464696.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值