HDU 3346 Lucky Number(简单题)

Lucky Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1240    Accepted Submission(s): 635

Problem Description

To Chinese people, 8 is a lucky number. Now your task is to judge if a number is lucky.
We say a number is lucky if it’s a multiple of 8, or the sum of digits that make up the number is a multiple of 8, or the sum of every digit’s square is a multiple of 8.

Input

The first line contains an integer stands for the number of test cases.
Each test case contains an integer n (n >= 0).

Output

For each case, output “Lucky number!” if the number is lucky, otherwise output “What a pity!”.

Sample Input

2

0

8

Sample Output

Lucky number!

Lucky number!

Author

dandelion

Source

HDU2010省赛集训队选拔赛(校内赛)

Recommend

lcy

 解题报告:简单题,就是判断一个数、每位数的和或者每位数平方的和能被8整除,就是一个Lucky number!

代码如下:

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
int main()
{
int n, t, sum1, flag, sum2;
scanf("%d", &t);
while (t --)
{
flag = 0;
scanf("%d", &n);
if (n == 0 || n % 8 == 0)
{
flag = 1;
}
else
{
sum1 = 0;
sum2 = 0;
while (n)
{
sum1 += n % 10;
sum2 += (n % 10) * (n % 10);
n = n / 10;
}
}
if (sum1 % 8 == 0 || sum2 % 8 == 0)
{
flag = 1;
}
if (flag)
{
printf("Lucky number!\n");
}
else
{
printf("What a pity!\n");
}
}
return 0;
}



转载于:https://www.cnblogs.com/lidaojian/archive/2012/04/01/2429477.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值