URAL 1776 C - Anniversary Firework DP

C - Anniversary Firework
Time Limit: 20 Sec

Memory Limit: 256 MB

题目连接

http://acm.hust.edu.cn/vjudge/contest/view.action?cid=87643#problem/B

Description

Denis has to prepare the Ural State University 90th anniversary firework. He bought  n rockets and started to think of the way he should launch them. After a pair of sleepless nights he invented the following algorithm.
All  n rockets are placed on the surface in a single line. The interval between two consecutive salvos is ten seconds. The leftmost and the rightmost rocket are launched in the first salvo. After  i salvos are fired, all non-empty segments between two neighboring launched rockets are considered. One rocket is chosen randomly and uniformly at each of these segments. All chosen rockets are launched in the ( i + 1)-st salvo. Algorithm runs until all rockets are launched.
Calculate the average duration in seconds of such a firework.
 
 

Input

The only input line contains an integer n (3 ≤ n ≤ 400) , which is the number of rockets bought by Denis.

Output

Output the expected duration of the firework in seconds, with absolute or relative error not exceeding 10 −6.

Sample Input

5

Sample Output

26.66666666666

HINT

 

题意

有n个火箭,每次你都会在已经放了火箭的区间内随机选择一个放火箭

然后问你把火箭全部放完的期望时间是多少

题解

首先,期望取最大值这个是错误的

这个dp[i][j]应该表示长度为i的,放j个火箭的概率是多少

直接dfs解决就好了

代码:

//qscqesze
#include <cstdio>
#include <cmath>
#include <cstring>
#include <ctime>
#include <iostream>
#include <algorithm>
#include <set>
#include <vector>
#include <sstream>
#include <queue>
#include <typeinfo>
#include <fstream>
#include <map>
#include <stack>
typedef long long ll;
using namespace std;
//freopen("D.in","r",stdin);
//freopen("D.out","w",stdout);
#define sspeed ios_base::sync_with_stdio(0);cin.tie(0)
#define maxn 5000
#define mod 10007
#define eps 1e-9
int Num;
//const int inf=0x7fffffff;   //нчоч╢С
const int inf=0x3f3f3f3f;
inline ll read()
{
    ll x=0,f=1;char ch=getchar();
    while(ch<'0'||ch>'9'){if(ch=='-')f=-1;ch=getchar();}
    while(ch>='0'&&ch<='9'){x=x*10+ch-'0';ch=getchar();}
    return x*f;
}
//**************************************************************************************

int v[500][500];
double dp[500][500];
double dfs(int x,int y)
{
    if(x==0)return 1.0;
    if(y==0)return 0.0;
    if(v[x][y])
        return dp[x][y];
    double p = 1.0/(x*1.0);
    double ans=0;
    for(int i=1;i<=x;i++)
        ans+=p*(dfs(i-1,y-1)*dfs(x-i,y-1));
    v[x][y]=1;
    dp[x][y]=ans;
    return ans;
}
int main()
{
    int n;
    cin>>n;
    double ans=0;
    for(int i=1;i<=n-2;i++)
        ans+=(dfs(n-2,i)-dfs(n-2,i-1))*(1.0*10*i);
    printf("%.10lf\n",ans);
}

 

转载于:https://www.cnblogs.com/qscqesze/p/4728590.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值