-------Pokemon Master------很水-------

A - Pokemon Master
Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%lld & %llu
Submit
 
Status
Description
Calem and Serena are pokemon masters. One day they decided to have a pokemon battle practice before Pokemon World Championships. Each of them has some pokemons in each's team. To make the battle more interesting, they decided to use a special rule to determine the winner: the team with heavier total weight will win the battle!

Input
There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains two integers N and M (1 <= N, M <= 6), which describes that Calem has N pokemons and Serena has M pokemons.

The second line contains N integers indicating the weight of Calem's pokemons. The third line contains M integers indicating the weight of Serena's pokemons. All pokemons' weight are in the range of [1, 2094] pounds.

Output
For each test case, output "Calem" if Calem's team will win the battle, or "Serena" if Serena's team will win. If the two team have the same total weight, output "Draw" instead.

Sample Input
1
6 6
13 220 199 188 269 1014
101 176 130 220 881 396
Sample Output
Serena

臭长题目其实没有多少技术含量.

意思就是  第一行数据是测试案例数.  第二行是   每个人拥有的拥有的什么鬼东西的重量,让你求出分别拥有的重量之和,谁的大谁就赢了.平局的话输出平局.

#include<stdio.h>
int main()
{
    int t, n, m;
    scanf("%d", &t);
    while (t--)
    {
        scanf("%d %d", &n, &m);
        int i, num, s1 = 0, s2 = 0;
        for (i = 0; i < n; i++)
        {
            scanf("%d", &num);
            s1 += num;
        }
        for (i = 0; i < m; i++)
        {
            scanf("%d", &num);
            s2 += num;
        }
        if (s1 == s2)
            printf("Draw");
        else
            printf(s1 > s2 ? "Calem" : "Serena");   //这里运用了三目运算符   很节省篇幅.......值得学习,如果?之前的条件成立的话,就执行紧挨着的,否则就执行:后面的
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/A-FM/p/5096615.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值