Pokemon Master

Calem and Serena are pokemon masters. One day they decided to have a pokemon battle practice before Pokemon World Championships. Each of them has some pokemons in each's team. To make the battle more interesting, they decided to use a special rule to determine the winner: the team with heavier total weight will win the battle!

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains two integers N and M (1 <= N, M <= 6), which describes that Calem has Npokemons and Serena has M pokemons.

The second line contains N integers indicating the weight of Calem's pokemons. The third line contains M integers indicating the weight of Serena's pokemons. All pokemons' weight are in the range of [1, 2094] pounds.

Output

For each test case, output "Calem" if Calem'steam will win the battle, or "Serena" if Serena'steam will win. If the two team have the same total weight, output "Draw" instead.

Sample Input

1
6 6
13 220 199 188 269 1014
101 176 130 220 881 396

Sample Output

Serena

AC代码(小弱鸡不得不吐槽一下水的一批)

#include <iostream>
#include <bits/stdc++.h>
using namespace std;

int main()
{
    int t, n, m, i, x;
    long long sum, sm;
    while(scanf("%d",&t)!=EOF)
    {
        while(t--)
        {
           sum = sm = 0;
            scanf("%d%d",&n,&m);
            for(i = 0;i<n;i++)
            {
                scanf("%d",&x);
                sum = sum + x;
            }
            for(i = 0;i<m;i++)
            {
                scanf("%d",&x);
                sm = sm + x;
            }
            if(sum>sm)
            printf("Calem\n");
            else if(sum==sm)
                printf("Draw\n");
            else
                printf("Serena\n");
        }
    }
    return 0;
}
Pokemon数据集是一个包含了关于Pokemon(宠物小精灵)的信息的数据集。这个数据集中收集了数百种Pokemon的属性、能力、技能、种族值等详细信息,可以用来进行各种数据分析和机器学习任务。 这个数据集中的属性信息包括每只Pokemon的种类、身高、重量、颜色等等。能力信息包括每只Pokemon的生命值、攻击力、防御力、速度等等。技能信息包括每只Pokemon可以使用的特殊技能、物理技能和状态技能。种族值则是一种用来表示Pokemon基础能力值的指标,能够影响Pokemon在战斗中的表现。 通过对Pokemon数据集进行分析,我们可以了解每个种类Pokemon的平均属性值、能力分布和技能种类等等。比如,我们可以分析哪些Pokemon的攻击力和速度高,哪些Pokemon的特殊防御力比较低,以及它们之间的关联性等。这对于创作游戏策略、进行角色平衡的调整等方面都有着重要的作用。 此外,Pokemon数据集还可以用于机器学习的任务。我们可以利用这些数据训练模型来预测Pokemon的属性、种族值等信息,或者构建一个可以根据Pokemon的属性和技能来推荐最佳战斗队伍的模型。这些模型可以在游戏中用于AI对战、自动战斗等功能。 总之,Pokemon数据集是一个提供了Pokemon相关信息的数据集,对于理解和分析Pokemon的属性、能力以及进行相关的机器学习任务具有重要意义。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值