Codeforces 713 C Sonya and Problem Wihtout a Legend

Description

Sonya was unable to think of a story for this problem, so here comes the formal description.
You are given the array containing \(n\) positive integers. At one turn you can pick any element and increase or decrease it by \(1\). The goal is the make the array strictly increasing by making the minimum possible number of operations. You are allowed to change elements in any way, they can become negative or equal to \(0\).

Input

The first line of the input contains a single integer \(n (1  \le  n \le 3000)\) — the length of the array.
Next line contains \(n\) integer \(a_{i}(1 \le a_{i} \le  10^{9})\).

Output

Print the minimum number of operation required to make the array strictly increasing.

Sample Input

7
2 1 5 11 5 9 11

Sample Output

9

BZOJ1049 数字序列类似,所有我想到了\(O(N^{3})\)做法,果断TLE。标解懂了些,做法太神了,什么维护中位数,但就是不知道转移怎么会没有后效性。
此处介绍另一种做法。首先也是将单调上升变为单调不降(见BZOJ1049 数字序列)。\(f_{i,j}\)表示前\(i\)个数,最大为\(j\)的合法序列最小代价。转移方程
\[f_{i,j} = min\{f_{i-1,k} \}+\mid A_{i}-j \mid(k \le j)\]
当然\(A\)值域太大,我们可以离散化。代码如下:

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstdlib>
#include<cstring>
using namespace std;

typedef long long ll;
#define inf (1LL<<50)
#define maxn (3010)
int N,cnt; ll f[maxn][maxn],ans = inf,A[maxn],B[maxn];

int main()
{
    freopen("E.in","r",stdin);
    freopen("E.out","w",stdout);
    scanf("%d",&N);
    for (int i = 1;i <= N;++i) scanf("%I64d",A+i),A[i] -= i;
    memcpy(B,A,sizeof(B)); B[N+1] = -inf,B[N+2] = inf;
    sort(B+1,B+N+3); cnt = unique(B+1,B+N+3)-B-1;
    A[0] = -inf; A[N+1] = inf;
    memset(f,0x7,sizeof(f)); f[0][1] = 0;
    for (int i = 1;i <= N+1;++i)
    {
        ll tmp = inf;
        for (int j = 1;j <= cnt;++j)
            tmp = min(tmp,f[i-1][j]),f[i][j] = tmp+abs(A[i]-B[j]);
    }
    for (int i = 1;i <= cnt;++i) ans = min(ans,f[N+1][i]);
    printf("%I64d",ans);
    fclose(stdin); fclose(stdout);
    return 0;
}

转载于:https://www.cnblogs.com/mmlz/p/5879421.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值