画柱状图Java

样例输入:
THE QUICK BROWN FOX JUMPED OVER THE LAZY DOG.
THIS IS AN EXAMPLE TO TEST FOR YOUR
HISTOGRAM PROGRAM.
HELLO! 
样例输出:

                            *

                            *

        *                   *

        *                   *     *   *

        *                   *     *   *

*       *     *             *     *   *

*       *     * *     * *   *     * * *

*       *   * * *     * *   * *   * * * *

*     * * * * * *     * * * * *   * * * *     * *

* * * * * * * * * * * * * * * * * * * * * * * * * *

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

题目的意思是从命令行输入一个大写的字符串,求一个字符出现的频率,画出来。

import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;
import java.util.Arrays;
 
public class Main {
 
    public static void main(String[] args) throws NumberFormatException,
           IOException {
       BufferedReader read = new BufferedReader(new InputStreamReader(
              System.in));
       int[] a = new int[26];
       int tt;
       for (int i = 0; i < 4; i++) {
           String str = read.readLine();
           for (int j = 0; j < str.length(); j++) {
              tt = str.charAt(j) - 'A';
              if (tt >= 0 && tt <= 25) {
                  a[tt]++;
              }
           }
       }
       int max = 0;
       for (int i = 0; i < 26; i++) {
           if (a[i] > max) {
              max = a[i];
           }
       }
       char[][] c = new char[max + 1][51];
       for (int i = 0; i < max + 1; i++) {
           Arrays.fill(c[i], ' ');
       }
       for (int i = 0; i < 26; i++) {
           int h = a[i];
           for (int j = 0; j < h; j++) {
              c[max - 1 - j][i * 2] = '*';
           }
       }
       for (int i = 0; i < 26; i++) {
           c[max][i * 2] = (char) ('A' + i);
       }
       for (int i = 0; i < max + 1; i++) {
           String str = String.valueOf(c[i]);
           while (str.endsWith(" ")) {
              str = str.substring(0, str.length() - 1);
           }
           System.out.println(str);
       }
    }

 

转载于:https://www.cnblogs.com/airycode/p/5192467.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值