POJ 3267 The Cow Lexicon 动态规划

The Cow Lexicon
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 6999 Accepted: 3242

Description

Few know that the cows have their own dictionary with W (1 ≤ W ≤ 600) words, each containing no more 25 of the characters 'a'..'z'. Their cowmunication system, based on mooing, is not very accurate; sometimes they hear words that do not make any sense. For instance, Bessie once received a message that said "browndcodw". As it turns out, the intended message was "browncow" and the two letter "d"s were noise from other parts of the barnyard.

The cows want you to help them decipher a received message (also containing only characters in the range 'a'..'z') of length L (2 ≤ L ≤ 300) characters that is a bit garbled. In particular, they know that the message has some extra letters, and they want you to determine the smallest number of letters that must be removed to make the message a sequence of words from the dictionary.

Input

Line 1: Two space-separated integers, respectively:   W  and   L   Line 2:   L  characters (followed by a newline, of course): the received message   Lines 3.. W+2: The cows' dictionary, one word per line

Output

Line 1: a single integer that is the smallest number of characters that need to be removed to make the message a sequence of dictionary words.

Sample Input

6 10
browndcodw
cow
milk
white
black
brown
farmer

Sample Output

2
代码:
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std ;
#define MAXN 610
#define MAX 310
char word[MAX] ;
char a[MAXN][MAXN] ;
int len[MAXN] ,dp[MAXN] ;
int main()
{
	int i , j , n , m ;
	int k , p ;
	while( scanf( "%d%d" ,&n , &m ) != EOF )
	{
		cin >> word ;
		for( i = 1; i <= n ;i++)
		{
			scanf( "%s" , a[i] ) ;
			len[i] = strlen( a[i] ) ;
		}
		memset( dp , 0 ,sizeof(dp) ) ;
		for( i = 1 ; i <= m ; i++)
		{
			dp[i] = dp[i-1] + 1 ; // 如果不匹配就是加一
			for( j = 1 ;j <= n ;j++)
			{
				k = len[j] - 1 ;
				p = i - 1;
				while( k >= 0 && p >= 0)
				{
					if( a[j][k] == word[p] )
					{
						k-- ;
					}
					p-- ;
				}
				if( k < 0 )
				{
					dp[i] = min(dp[i], dp[p + 1] + i - p - 1 - len[j]);   
					// i - p - 1 - len[j] 是第j个单词匹配成功时要去掉的单词数
					// 转移方程 dp[i] = min( dp[i] ,dp[p+1]+i - p - 1 - len[j] )
					// 既 取 (第i 个不匹配) 和 (匹配)两者 去掉字符的最小值
				}
			}
		}
		cout << dp[m] << endl ;
	}
}

  

转载于:https://www.cnblogs.com/20120125llcai/archive/2013/05/08/3067823.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值