The Cow Lexicon

The Cow Lexicon
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 8815 Accepted: 4162

Description

Few know that the cows have their own dictionary with W (1 ≤ W ≤ 600) words, each containing no more 25 of the characters ‘a’..’z’. Their cowmunication system, based on mooing, is not very accurate; sometimes they hear words that do not make any sense. For instance, Bessie once received a message that said “browndcodw”. As it turns out, the intended message was “browncow” and the two letter “d”s were noise from other parts of the barnyard.

The cows want you to help them decipher a received message (also containing only characters in the range ‘a’..’z’) of length L (2 ≤ L ≤ 300) characters that is a bit garbled. In particular, they know that the message has some extra letters, and they want you to determine the smallest number of letters that must be removed to make the message a sequence of words from the dictionary.

Input
Line 1: Two space-separated integers, respectively: W and L
Line 2: L characters (followed by a newline, of course): the received message
Lines 3..W+2: The cows’ dictionary, one word per line

Output
Line 1: a single integer that is the smallest number of characters that need to be removed to make the message a sequence of dictionary words.

Sample Input

6 10
browndcodw
cow
milk
white
black
brown
farmer

Sample Output

2

Source
USACO 2007 February Silver
求主串与字典之间匹配要删除的字符数

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <queue>
#include <algorithm>
#define LL long long
using namespace std;

const int INF = 0x3f3f3f3f;

const int MAX = 20001;

int dp[400];//记录从i到L之间要匹配字典要删除的字符数目

char s[400];

char str[650][400];

int len[650];

int main()
{
    int n,L;
    while(~scanf("%d %d",&n,&L))
    {
        scanf("%s",s);
        for(int i=0;i<n;i++)
        {
            scanf("%s",str[i]);
            len[i]=strlen(str[i]);
        }
        memset(dp,0,sizeof(dp));
        for(int i=L-1;i>=0;i--)
        {
            dp[i]=dp[i+1]+1;//最坏的情况,将字符删除
            for(int j=0;j<n;j++)//将i到L之间的字符与字典进行匹配
            {
                if(str[j][0]==s[i]&&i+len[j]<=L)
                {
                    int ss=i;
                    int t=0;
                    while(ss<L)
                    {
                        if(str[j][t]==s[ss++])
                        {
                            t++;
                        }
                        if(t==len[j])//如果能够匹配,计算最小值
                        {
                            dp[i]=min(dp[i],dp[ss]+ss-i-len[j]);//对于ss,ss到L之间的匹配是已经算出来了,dp[ss]+ss-i-len[j]表示i到L之间匹配要删除的字符数,求最小值
                            break;
                        }
                    }
                }
            }
        }
        printf("%d\n",dp[0]);
    }

    return 0;
}

转载于:https://www.cnblogs.com/juechen/p/5255981.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值