nyoj 151 Biorhythms

描述

Some people believe that there are three cycles in a person's life that start the day he or she is born. These three cycles are the physical, emotional, and intellectual cycles, and they have periods of lengths 23, 28, and 33 days, respectively. There is one peak in each period of a cycle. At the peak of a cycle, a person performs at his or her best in the corresponding field (physical, emotional or mental). For example, if it is the mental curve, thought processes will be sharper and concentration will be easier. 
Since the three cycles have different periods, the peaks of the three cycles generally occur at different times. We would like to determine when a triple peak occurs (the peaks of all three cycles occur in the same day) for any person. For each cycle, you will be given the number of days from the beginning of the current year at which one of its peaks (not necessarily the first) occurs. You will also be given a date expressed as the number of days from the beginning of the current year. You task is to determine the number of days from the given date to the next triple peak. The given date is not counted. For example, if the given date is 10 and the next triple peak occurs on day 12, the answer is 2, not 3. If a triple peak occurs on the given date, you should give the number of days to the next occurrence of a triple peak. 

输入
You will be given at most 1000000 cases. The input for each case consists of one line of four integers p, e, i, and d. The values p, e, and i are the number of days from the beginning of the current year at which the physical, emotional, and intellectual cycles peak, respectively. The value d is the given date and may be smaller than any of p, e, or i. All values are non-negative and at most 365, and you may assume that a triple peak will occur within 21252 days of the given date. The end of input is indicated by a line in which p = e = i = d = -1
输出
For each test case, print the number of days to the next triple peak, in the form:
样例输入

0 0 0 0
0 0 0 100
5 20 34 325
4 5 6 7
283 102 23 320
203 301 203 40
-1 -1 -1 -1

样例输出

21252
21152
19575
16994
8910
10789

学信安的我表示学过中国剩余定理但是做题还是不会…..
还要看别人博客才知道要用到中国剩余定理,妈卖批!!!

中国剩余定理:
基本公式为:x+d=M1*y1*p+M2*y2*e+M3*y3*i
x+d=p(mod 23);
x+d=e(mod 23);
x+d=i(mod 23);
M=23*28*33=21252,M1=924,M2=759,M3=644;
924y1=1(mod 23);
644y3=1mod 33);
(这个是由Mk*yk=1(mod mk 可以知道 至于为 什么 我还是从一 篇别人的博客里知道的 至于原因 也没有写)
可以得出来:y1=6,y2=19,y3=2;
进而:x+d=(5544*p+14421*e+1288*i)%21252;
注意:x不能是负数,所以修改为x=(5544*p+14421*e+1288*i-d+21252)%21252;

#include<cstdio>
using namespace std;
int main()
{
    int p, e, i, d, icase = 0, x;
    while (scanf("%d%d%d%d", &p, &e, &i, &d), ~p)
    {
        x = (5544 * p + 14421 * e + 1288 * i - d + 21252) % 21252;
        if (x == 0)
            x = 21252;
        printf("%d\n",x);
    }
    return 0;
}        

转载于:https://www.cnblogs.com/nyist-xsk/p/7264807.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值