poj2785双向搜索

The SUM problem can be formulated as follows: given four lists A, B, C, D of integer values, compute how many quadruplet (a, b, c, d ) ∈ A x B x C x D are such that a + b + c + d = 0 . In the following, we assume that all lists have the same size n .

Input

The first line of the input file contains the size of the lists n (this value can be as large as 4000). We then have n lines containing four integer values (with absolute value as large as 2  28 ) that belong respectively to A, B, C and D .

Output

For each input file, your program has to write the number quadruplets whose sum is zero.

Sample Input

6
-45 22 42 -16
-41 -27 56 30
-36 53 -37 77
-36 30 -75 -46
26 -38 -10 62
-32 -54 -6 45

Sample Output

5

Hint

Sample Explanation: Indeed, the sum of the five following quadruplets is zero: (-45, -27, 42, 30), (26, 30, -10, -46), (-32, 22, 56, -46),(-32, 30, -75, 77), (-32, -54, 56, 30).
题意:求四个数的和为0的情况有几种
题解:折半枚举+sort,,很重要的小技巧:upper_bound(a,a+n,s)-low_bound(a,a+n,s)表示a数组(已排序)里等于s的个数,
刚开始用 if(all[lower_bound(all,all+n*n,-a[i]-b[j])-all]==-a[i]-b[j])处理wa了,发现原来是因为只算了一个相等的情况,要是有几个同时等于就漏了
#include<map>
#include<set>
#include<cmath>
#include<queue>
#include<stack>
#include<vector>
#include<cstdio>
#include<iomanip>
#include<cstdlib>
#include<cstring>
#include<iostream>
#include<algorithm>
#define pi acos(-1)
#define ll long long
#define mod 1000000007

using namespace std;

const double g=10.0,eps=1e-9;
const int N=4000+5,maxn=10000+5,inf=0x3f3f3f3f;

ll a[N],b[N],c[N],d[N];
ll all[N*N];

int main()
{
    ios::sync_with_stdio(false);
    cin.tie(0);
 //   cout<<setiosflags(ios::fixed)<<setprecision(2);
    ll n;
    while(cin>>n){
        for(ll i=0;i<n;i++)cin>>a[i]>>b[i]>>c[i]>>d[i];
        for(ll i=0;i<n;i++)
        {
            for(ll j=0;j<n;j++)
            {
                all[i*n+j]=c[i]+d[j];
            }
        }
        sort(all,all+n*n);
        ll ans=0;
        for(ll i=0;i<n;i++)
        {
            for(ll j=0;j<n;j++)
            {
                ans+=upper_bound(all,all+n*n,-a[i]-b[j])-lower_bound(all,all+n*n,-a[i]-b[j]);
            }
        }
        cout<<ans<<endl;
    }
    return 0;
}
View Code

 

转载于:https://www.cnblogs.com/acjiumeng/p/6757106.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值