练习赛2(补题)HDU 1058 Humble Numbers 数学题

问题 A: 丑数

题目描述

如果一个数的素因子只包含2,3,5或7,那么我们把这种数叫做丑数。序列1,2,3,4,5,6,7,8,9,10,12,14,15,16,18,20,21,24,25,27...展示了前20个丑数。
请你编程寻找这个序列中的第n个元素。

输入

输入包含多组测试数据。每组输入为一个整数n(1<=n<=5842),当n=0时,输入结束。

输出

对于每组输入,输出一行“The nth humble number is number.”。里面的n由输入中的n值替换,“st”,“nd”,“rd”和“th”这些序数结尾的用法参照输出样例。

样例输入

1
2
3
4
11
12
13
21
22
23
100
1000
5842
0

样例输出

The 1st humble number is 1.
The 2nd humble number is 2.
The 3rd humble number is 3.
The 4th humble number is 4.
The 11th humble number is 12.
The 12th humble number is 14.
The 13th humble number is 15.
The 21st humble number is 28.
The 22nd humble number is 30.
The 23rd humble number is 32.
The 100th humble number is 450.
The 1000th humble number is 385875.
The 5842nd humble number is 2000000000.

思路:第n个数必然由n-1个数中的某个数*{2,3,5,7}得到。

而这第n个数需要满足两个条件:

1:f[n]>f[n-1]。

2:f[n]在满足条件1的情况下取最小值。

#include<stdio.h>

#define N 5849
long long f[N];
int main()
{
	int i,j,k,n;
	
	int next[4] = {2,3,5,7};
	f[1] = 1;
	for( i = 2; i <= 5842; i ++)
	{
		f[i] = 2000000001;
		for(j = 0; j < 4; j ++)
		{
			for( k = i-1; k >= 1; k --)
			{
				if(f[k]*next[j] <= f[i-1])
					break;
				if(f[k]*next[j] < f[i])
					f[i] = f[k]*next[j];
			}
		}
	}
	while(scanf("%d",&n),n!= 0)
	{
		printf("The %d",n);
		if(n %10 == 1&&n%100!= 11)
			printf("st");
		else if(n%10 == 2&&n %100!= 12)
			printf("nd");
		else if(n%10 == 3&& n %100!=13 )
			printf("rd");
		else
		 	printf("th");
		printf(" humble number is %lld.\n",f[n]);
	}
	return 0;
}


转载于:https://www.cnblogs.com/hellocheng/p/7350118.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值