7.23 练习题 A: 丑数

问题 A: 丑数

时间限制: 1 Sec  内存限制: 32 MB
提交: 20  解决: 4
[提交][状态][讨论版]

题目描述

如果一个数的素因子只包含2,3,5或7,那么我们把这种数叫做丑数。序列1,2,3,4,5,6,7,8,9,10,12,14,15,16,18,20,21,24,25,27...展示了前20个丑数。
请你编程寻找这个序列中的第n个元素。

输入

输入包含多组测试数据。每组输入为一个整数n(1<=n<=5842),当n=0时,输入结束。

输出

对于每组输入,输出一行“The nth humble number is number.”。里面的n由输入中的n值替换,“st”,“nd”,“rd”和“th”这些序数结尾的用法参照输出样例。

样例输入

1

2

3

4

11

12

13

21

22

23

100

1000

5842

0


样例输出

The 1st humble number is 1.

The 2nd humble number is 2.

The 3rd humble number is 3.

The 4th humble number is 4.

The 11th humble number is 12.

The 12th humble number is 14.

The 13th humble number is 15.

The 21st humble number is 28.

The 22nd humble number is 30.

The 23rd humble number is 32.

The 100th humble number is 450.

The 1000th humble number is 385875.

The 5842nd humble number is2000000000.


#include<stdio.h>
int a[300000];
int s(int a,int b,int c,int d)
{
	if(a>b)
		a=b;
	if(a>c)
		a=c;
	if(a>d)
		a=d;
	return a;	
}
int main()
{
	int i,j,k,l,m,n,t1,t2,t3,t4,t;
	t1=t2=t3=t4=1;
	a[1]=1;
	for(i=2;i<=6000;i++)
	{
		a[i]=s(a[t1]*2,a[t2]*3,a[t3]*5,a[t4]*7);
		if(a[i]==a[t1]*2) 
		{
            t1++;
        }
        if(a[i]==a[t2]*3) 
		{
            t2++;
        }
        if(a[i]==a[t3]*5) 
		{
            t3++;
        }
        if(a[i]==a[t4]*7) 
		{
            t4++;
        }
	}
	while(scanf("%d",&n),n)
	{
		if(n%10==1&&n%100!=11)
		{
			printf("The %dst humble number is %d.\n",n,a[n]);
		}
		else if(n%10==2&&n%100!=12)
		{
			printf("The %dnd humble number is %d.\n",n,a[n]);
		}
		else if(n%10==3&&n%100!=13)
		{
			printf("The %drd humble number is %d.\n",n,a[n]);
		}
		else
		{
			printf("The %dth humble number is %d.\n",n,a[n]);
		}
	}

	return 0;
}





  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值