POJ 2196 Computer(搜索-深度优先搜索)

Computer


Problem Description
A school bought the first computer some time ago(so this computer's id is 1). During the recent years the school bought N-1 new computers. Each new computer was connected to one of settled earlier. Managers of school are anxious about slow functioning of the net and want to know the maximum distance Si for which i-th computer needs to send signal (i.e. length of cable to the most distant computer). You need to provide this information. 


Hint: the example input is corresponding to this graph. And from the graph, you can see that the computer 4 is farthest one from 1, so S1 = 3. Computer 4 and 5 are the farthest ones from 2, so S2 = 2. Computer 5 is the farthest one from 3, so S3 = 3. we also get S4 = 4, S5 = 4.
 

Input
Input file contains multiple test cases.In each case there is natural number N (N<=10000) in the first line, followed by (N-1) lines with descriptions of computers. i-th line contains two natural numbers - number of computer, to which i-th computer is connected and length of cable used for connection. Total length of cable does not exceed 10^9. Numbers in lines of input are separated by a space.
 

Output
For each case output N lines. i-th line must contain number Si for i-th computer (1<=i<=N).
 

Sample Input
 
  
5 1 1 2 1 3 1 1 1
 

Sample Output
 
  
3 2 3 4 4
 

Author
scnu
 

Recommend
lcy   |   We have carefully selected several similar problems for you:   1561  1011  3456  1520  2242 
 

题目大意:

告诉你一棵树,问你某个点最远能到达多远?

解题思路:

先从1号点出发,找出各个点到1号点的距离,最远的那个点必然是树的主枝干上的一点。

从树的主干上的那点出发,距离最远的另一点必然是树主枝干的另一点。

接下来的答案就是每个点到两个主干点的距离取大。


解题代码:

#include <iostream>
#include <cstdio>
#include <climits>
#include <map>
#include <vector>
#include <algorithm>
using namespace std;

const int maxn=11000;

struct edge{
    int u,v,w;
    int next;
    edge(int u0=0,int v0=0,int w0=0){ u=u0;v=v0;w=w0;}
}e[maxn*2];

int n,cnt,head[maxn],d[maxn],dx[maxn],dy[maxn];

void initial(){
    cnt=0;
    for(int i=0;i<=n;i++) head[i]=-1;
}

void addedge(int u,int v,int w){
    e[cnt]=edge(u,v,w);e[cnt].next=head[u];head[u]=cnt++;
}

void input(){
    int x,y,w0;
    for(int i=2;i<=n;i++){
        scanf("%d%d",&y,&w0);
        addedge(i,y,w0);
        addedge(y,i,w0);
    }
}

void dfs(int u,int fa,int dis,int *d){
    for(int i=head[u];i!=-1;i=e[i].next){
        int v=e[i].v,w=e[i].w;
        if(v!=fa) dfs(v,u,d[v]=dis+w,d);
    }
}

void solve(){
    int x=1,y=1;
    dfs(1,-1,d[1]=0,d);
    for(int i=1;i<=n;i++) if(d[x]<d[i]) x=i;
    dfs(x,-1,dx[x]=0,dx);
    for(int i=1;i<=n;i++) if(dx[y]<dx[i]) y=i;
    dfs(y,-1,dy[y]=0,dy);
    for(int i=1;i<=n;i++) d[i]=max(dx[i],dy[i]);
    for(int i=1;i<=n;i++) printf("%d\n",d[i]);
}

int main(){
    while(scanf("%d",&n)!=EOF){
        initial();
        input();
        solve();
    }
    return 0;
}





版权声明:欢迎关注我的博客,本文为博主toyking原创文章,未经博主允许不得转载。

转载于:https://www.cnblogs.com/toyking/p/4951009.html

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值