ACM-ICPC 2018 焦作赛区网络预赛 I Save the Room

Bob is a sorcerer. He lives in a cuboid room which has a length of AAA, a width of BBB and a height of CCC, so we represent it as AAA * BBB * CCC. One day, he finds that his room is filled with unknown dark energy. Bob wants to neutralize all the dark energy in his room with his light magic. He can summon a 111 * 111 * 222 cuboid at a time to neutralize dark energy. But the cuboid must be totally in dark energy to take effect. Can you foresee whether Bob can save his room or not?

Input

Input has TTT test cases. T≤100T \le 100T100

For each line, there are three integers A,B,CA, B, CA,B,C.

1≤A,B,C≤1001 \le A, B, C \le 1001A,B,C100

Output

For each test case, if Bob can save his room, print"Yes", otherwise print"No".

样例输入
1 1 2
1 1 4
1 1 1
样例输出
Yes
Yes
No

题意:
给你一个任意的长方体,问你能否用1*1*2的长方体将所给的长方体恰好填充满

题解:
水题,给出的长方体为1*1*2,所以只要输入的长方体的长宽高中有一条边为偶数就可以,即可以整除2.另两条边就可以为任意数,因为任意的数都是1的倍数,总是能放下的。


代码:
#include <bits/stdc++.h>

using namespace std;

int main()
{
    int n,m,k;
    while(scanf("%d%d%d",&n,&m,&k)!=EOF){
        if(n%2==0||m%2==0||k%2==0) printf("Yes\n");
        else printf("No\n");
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/y1040511302/p/9655246.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值