HOJ 1438 The Tower of Babylon(线性DP)

The Tower of Babylon
My Tags
Cancel - Seperate tags with commas.
Source : University of Ulm Internal Contest 1996
Time limit : 5 sec Memory limit : 32 M
Submitted : 303, Accepted : 155
Perhaps you have heard of the legend of the Tower of Babylon. Nowadays many details of this tale have been forgotten. So now, in line with the educational nature of this contest, we will tell you the whole story:
The babylonians had n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height.
They wanted to construct the tallest tower possible by stacking blocks. The problem was that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block. This meant, for example, that blocks oriented to have equal-sized bases couldn’t be stacked.
Your job is to write a program that determines the height of the tallest tower the babylonians can build with a given set of blocks.
Input Specification
The input file will contain one or more test cases. The first line of each test case contains an integer n,
representing the number of different blocks in the following data set. The maximum value for n is 30.
Each of the next n lines contains three integers representing the values xi, yi and zi.
Input is terminated by a value of zero (0) for n.
Output Specification
For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format “Case case: maximum height = height
Sample Input
1
10 20 30
2
6 8 10
5 5 5
7
1 1 1
2 2 2
3 3 3
4 4 4
5 5 5
6 6 6
7 7 7
5
31 41 59
26 53 58
97 93 23
84 62 64
33 83 27
0
Sample Output
Case 1: maximum height = 40
Case 2: maximum height = 21
Case 3: maximum height = 28
Case 4: maximum height = 342

思路:
一个长方体可以有三种摆放方式,将所有摆放方式按照长,宽排序,随便哪个优先,然后再求最大上升子序列,上升的含义是严格的长减少,宽减少

#include <iostream>
#include <string.h>
#include <stdlib.h>
#include <algorithm>
#include <math.h>

using namespace std;
struct Node
{
    int x;
    int y;
    int z;
}a[100];
int cmp(Node a,Node b)
{
    if(a.x==b.x)
        return a.y>b.y;
    return a.x>b.x;
}
int n;
int dp[100];
int vis[1000][1000];

int main()
{
    int l,w,h;
    int cas=0;
    while(scanf("%d",&n)!=EOF)
    {
        if(n==0)
            break;
        memset(vis,0,sizeof(vis));
        int cnt=0;
        for(int i=1;i<=n;i++)
        {
            scanf("%d%d%d",&l,&w,&h);
                Node term;
                term.x=l>w?l:w;term.y=l>w?w:l;term.z=h;
                a[++cnt]=term;
                Node term2;
                term2.x=l>h?l:h;term2.y=l>h?h:l;term2.z=w;
                a[++cnt]=term2;
                Node term3;
                term3.x=w>h?w:h;term3.y=w>h?h:w;term3.z=l;
                a[++cnt]=term3;

        }
        sort(a+1,a+cnt+1,cmp);
        a[cnt+1].x=-1;a[cnt+1].y=-1;a[cnt+1].z=0;
        for(int i=1;i<=cnt+1;i++)
        {
            int num=0;
            for(int j=i-1;j>=1;j--)
            {
                if(a[i].x<a[j].x&&a[i].y<a[j].y)
                {
                    num=max(num,dp[j]);
                }
            }
            dp[i]=num+a[i].z;
        }
        printf("Case %d: maximum height = %d\n",++cas,dp[cnt+1]);
    }
    return 0;
}

转载于:https://www.cnblogs.com/dacc123/p/8228802.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值