poj--2553--The Bottom of a Graph (scc+缩点)

The Bottom of a Graph

Time Limit : 6000/3000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other)
Total Submission(s) : 1   Accepted Submission(s) : 1
Problem Description
We will use the following (standard) definitions from graph theory. Let V be a nonempty and finite set, its elements being called vertices (or nodes). Let E be a subset of the Cartesian product V×V, its elements being called edges. Then G=(V,E) is called a directed graph.
Let n be a positive integer, and let p=(e1,...,en) be a sequence of length n of edges ei∈E such that ei=(vi,vi+1) for a sequence of vertices (v1,...,vn+1). Then p is called a path from vertex v1 to vertex vn+1 in G and we say that vn+1 is reachable from v1, writing (v1→vn+1).
Here are some new definitions. A node v in a graph G=(V,E) is called a sink, if for every node w in G that is reachable from v, v is also reachable from w. The bottom of a graph is the subset of all nodes that are sinks, i.e., bottom(G)={v∈V|∀w∈V:(v→w)⇒(w→v)}. You have to calculate the bottom of certain graphs.
 

Input
The input contains several test cases, each of which corresponds to a directed graph G. Each test case starts with an integer number v, denoting the number of vertices of G=(V,E), where the vertices will be identified by the integer numbers in the set V={1,...,v}. You may assume that 1<=v<=5000. That is followed by a non-negative integer e and, thereafter, e pairs of vertex identifiers v1,w1,...,ve,we with the meaning that (vi,wi)∈E. There are no edges other than specified by these pairs. The last test case is followed by a zero.
 

Output
For each test case output the bottom of the specified graph on a single line. To this end, print the numbers of all nodes that are sinks in sorted order separated by a single space character. If the bottom is empty, print an empty line.
 

Sample Input
 
  
3 3 1 3 2 3 3 1 2 1 1 2 0
 

Sample Output
 
  
1 3 2
#include<stdio.h>
#include<string.h>
#include<queue>
#include<stack>
#include<algorithm>
#include<vector>
using namespace std;
#define MAX 50010
struct node
{
	int u,v;
	int next;
}edge[MAX];
int low[MAX],dfn[MAX];
int sccno[MAX],head[MAX];
int scc_cnt,dfs_clock,cnt;
bool Instack[MAX];
int m,n;
stack<int>s;
vector<int>G[MAX];
vector<int>scc[MAX];
int in[MAX],out[MAX];
int num[MAX];
void init()
{
	memset(head,-1,sizeof(head));
	cnt=0;
}
void add(int u,int v)
{
	edge[cnt].u=u;
	edge[cnt].v=v;
	edge[cnt].next=head[u];
	head[u]=cnt++;
}
void getmap()
{
	int a,b;
	while(m--)
	{
		scanf("%d%d",&a,&b);
		add(a,b);
	}
}
void tarjan(int u,int fa)
{
	int v;
	low[u]=dfn[u]=++dfs_clock;
	s.push(u);
	Instack[u]=true;
	for(int i=head[u];i!=-1;i=edge[i].next)
	{
		v=edge[i].v;
		if(!dfn[v])
		{
			tarjan(v,u);
			low[u]=min(low[u],low[v]);
		}
		else if(Instack[v])
		low[u]=min(low[u],dfn[v]);
	}
	if(low[u]==dfn[u])
	{
		scc_cnt++;
		scc[scc_cnt].clear();
		for(;;)
		{
			v=s.top();
			s.pop();
			Instack[v]=false;
			scc[scc_cnt].push_back(v);
			sccno[v]=scc_cnt;
			if(v==u) break;
		}
	}
}
void find(int l,int r)
{
	memset(sccno,0,sizeof(sccno));
	memset(low,0,sizeof(low));
	memset(dfn,0,sizeof(dfn));
	memset(Instack,false,sizeof(Instack));
	dfs_clock=scc_cnt=0;
	for(int i=l;i<=r;i++)
	if(!dfn[i])
	tarjan(i,-1);
}
void suodian()
{
	for(int i=1;i<=scc_cnt;i++)
	G[i].clear(),in[i]=out[i]=0;
	for(int i=0;i<cnt;i++)
	{
		int u=sccno[edge[i].u];
		int v=sccno[edge[i].v];
		if(u!=v)
		G[u].push_back(v),out[u]++,in[v]++;
	}
}
void solve()
{
	int ans=0;
	int k=0;
	for(int i=1;i<=scc_cnt;i++)
	{
		if(out[i]==0)
		{
			for(int j=0;j<scc[i].size();j++)
			num[k++]=scc[i][j]; 
		}
	}
	sort(num,num+k);
	for(int i=0;i<k-1;i++)
	printf("%d ",num[i]);
	printf("%d\n",num[k-1]);
}
int main()
{
	while(scanf("%d%d",&n,&m),n)
	{
		init();
		getmap();
		find(1,n);
		suodian();
		solve();
	}
	return 0;
}

 

转载于:https://www.cnblogs.com/playboy307/p/5273780.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
POJ - 3616是一个题目,题目描述如下: 给定一组区间,每个区间有一个权重,要求选择一些区间,使得这些区间的右端点都小于等于k,并且权重之和最大。请问最大的权重和是多少? 解决这个问题的思路是使用动态规划。首先,将区间按照左端点从小到大进行排序。然后,定义一个dp数组,dp[i]表示右端点小于等于i的所有区间所能得到的最大权重。 接下来,遍历每一个区间,对于每个区间i,将dp[i]初始化为区间i的权重。然后,再遍历i之前的每个区间j,如果区间j的右端点小于等于k,并且区间j的权重加上区间i的权重大于dp[i],则更新dp[i]为dp[j]加上区间i的权重。 最后,遍历整个dp数组,找到最大的权重和,即为所求的答案。 下面是具体的代码实现: ```cpp #include <cstdio> #include <cstring> #include <algorithm> using namespace std; struct interval{ int start, end, weight; }; interval intervals[10005]; int dp[10005]; int n, m, k; bool compare(interval a, interval b) { if (a.start == b.start) { return a.end < b.end; } else { return a.start < b.start; } } int main() { while(~scanf("%d %d %d", &n, &m, &k)) { memset(dp, 0, sizeof dp); for (int i = 0; i < m; i++) { scanf("%d %d %d", &intervals[i].start, &intervals[i].end, &intervals[i].weight); } sort(intervals, intervals + m, compare); for (int i = 0; i < m; i++) { dp[i] = intervals[i].weight; for (int j = 0; j < i; j++) { if (intervals[j].end <= k && dp[j] + intervals[i].weight > dp[i]) { dp[i] = dp[j] + intervals[i].weight; } } } int maxWeight = 0; for (int i = 0; i < m; i++) { maxWeight = max(maxWeight, dp[i]); } printf("%d\n", maxWeight); } } ```

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值