poj2553-The Bottom of a Graph(强连通分量)

The Bottom of a Graph
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 7098 Accepted: 2905

Description

We will use the following (standard) definitions from graph theory. Let V be a nonempty and finite set, its elements being called vertices (or nodes). Let E be a subset of the Cartesian product V×V, its elements being called edges. Then G=(V,E) is called a directed graph.
Let n be a positive integer, and let p=(e1,...,en) be a sequence of length n of edges ei∈E such that ei=(vi,vi+1) for a sequence of vertices (v1,...,vn+1). Then p is called a path from vertex v1 to vertex vn+1 in G and we say that vn+1 is reachable from v1, writing (v1→vn+1).
Here are some new definitions. A node v in a graph G=(V,E) is called a sink, if for every node w in G that is reachable from v, v is also reachable from w. The bottom of a graph is the subset of all nodes that are sinks, i.e., bottom(G)={v∈V|∀w∈V:(v→w)⇒(w→v)}. You have to calculate the bottom of certain graphs.

Input

The input contains several test cases, each of which corresponds to a directed graph G. Each test case starts with an integer number v, denoting the number of vertices of G=(V,E), where the vertices will be identified by the integer numbers in the set V={1,...,v}. You may assume that 1<=v<=5000. That is followed by a non-negative integer e and, thereafter, e pairs of vertex identifiers v1,w1,...,ve,we with the meaning that (vi,wi)∈E. There are no edges other than specified by these pairs. The last test case is followed by a zero.

Output

For each test case output the bottom of the specified graph on a single line. To this end, print the numbers of all nodes that are sinks in sorted order separated by a single space character. If the bottom is empty, print an empty line.

Sample Input

3 3
1 3 2 3 3 1
2 1
1 2
0

Sample Output

1 3
2
找出度为零的强连通分量,把符合条件的点都输出出来。
#include<stdio.h>
#include<string.h>
#include<vector>
#include<stack>
using namespace std;
vector<int> vec[5005];
stack<int> sta;
int dfn[5005],low[5005];
int vis[5005];
int gro_id[5005],gro[5005];
int now,id;
int n,m;
void tarjan(int s)
{
    now++;
    vis[s]=2;
    dfn[s]=low[s]=now;
    sta.push(s);
    for(int i=0; i<vec[s].size(); i++)
    {
        if(vis[vec[s][i]]==0)
        {
            tarjan(vec[s][i]);
            low[s]=low[s]<low[vec[s][i]]?low[s]:low[vec[s][i]];
        }
        else if(vis[vec[s][i]]==2)
            low[s]=low[s]<dfn[vec[s][i]]?low[s]:dfn[vec[s][i]];
    }
    if(low[s]==dfn[s])
    {
        id++;
        while(1)
        {
            int t=sta.top();
            gro_id[t]=id;
            vis[t]=1;
            sta.pop();
            gro[id]++;
            if(t==s)
                break;
        }
    }
}
int main()
{
    while(scanf("%d",&n)&&n!=0)
    {
        now=id=0;
        scanf("%d",&m);
        //printf("123\n");
        memset(dfn,0,sizeof(dfn));
        memset(low,0,sizeof(low));
        memset(vis,0,sizeof(vis));
        memset(gro_id,0,sizeof(gro_id));
        memset(gro,0,sizeof(gro));
        //printf("123\n");
        for(int i=1; i<=n; i++)
            vec[i].clear();
        for(int i=0; i<m; i++)
        {
            int a,b;
            scanf("%d%d",&a,&b);
            vec[a].push_back(b);
        }
        //printf("123\n");
        for(int i=1; i<=n; i++)
            if(!vis[i])
                tarjan(i);
        //printf("123\n");
        memset(vis,0,sizeof(vis));
        int s=0;
        for(int i=1; i<=n; i++)
            for(int j=0; j<vec[i].size(); j++)
                if(gro_id[i]!=gro_id[vec[i][j]])
                {
                    if(vis[gro_id[i]]==0)
                        s++;
                    vis[gro_id[i]]=1;
                }
        if(s!=id)
        {
            for(int i=1; i<=n; i++)
            {
                if(vis[gro_id[i]]==0)
                    printf("%d ",i);
            }
        }
        printf("\n");
    }
    return 0;
}

  • 6
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值