hdu4405(概率dp)

Aeroplane chess

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2958    Accepted Submission(s): 1902


Problem Description
Hzz loves aeroplane chess very much. The chess map contains N+1 grids labeled from 0 to N. Hzz starts at grid 0. For each step he throws a dice(a dice have six faces with equal probability to face up and the numbers on the faces are 1,2,3,4,5,6). When Hzz is at grid i and the dice number is x, he will moves to grid i+x. Hzz finishes the game when i+x is equal to or greater than N.

There are also M flight lines on the chess map. The i-th flight line can help Hzz fly from grid Xi to Yi (0<Xi<Yi<=N) without throwing the dice. If there is another flight line from Yi, Hzz can take the flight line continuously. It is granted that there is no two or more flight lines start from the same grid.

Please help Hzz calculate the expected dice throwing times to finish the game.
 

Input
There are multiple test cases. 
Each test case contains several lines.
The first line contains two integers N(1≤N≤100000) and M(0≤M≤1000).
Then M lines follow, each line contains two integers Xi,Yi(1≤Xi<Yi≤N).  
The input end with N=0, M=0. 
 

Output
For each test case in the input, you should output a line indicating the expected dice throwing times. Output should be rounded to 4 digits after decimal point.
 

Sample Input
 
  
2 0 8 3 2 4 4 5 7 8 0 0
 

Sample Output
 
  
1.1667 2.3441

题意:
飞行棋,从0到n,置骰子,置到几就往前走几步,前进中会有捷径,比如2和5连到一起了,那你走到2时可以直接跳到5,如果5和8连到一起了,那你还可以继续跳到8,最后问跳到n时平均置几次骰子。也就是求期望。

概率dp入门。用dp[i]表示走到i的平均步数。其中dp[i]=dp[i]/6+1;其实可以表示为

                for(int j=1; j<=6; j++)
                    dp[i]+=dp[i+j]+1;
                dp[i]=dp[i]/6.0;
这样更容易理解~~

#include <iostream>
#include <stdio.h>
#include <stdlib.h>
#include<string.h>
#include<algorithm>
#include<math.h>
#include<queue>
#include<iomanip>
using namespace std;
typedef long long ll;
using namespace std;
int f[100010];
double dp[100010];
int main()
{
    int n,m;
    while(~scanf("%d%d",&n,&m)&&m+n)
    {
        memset(f,-1,sizeof(f));
        memset(dp,0,sizeof(dp));
        while(m--)
        {
            int a,b;
            scanf("%d%d",&a,&b);
            f[a]=b;
        }
        for(int i=n-1; i>=0; i--)
        {
            if(f[i]!=-1)
                dp[i]=dp[f[i]];
            else
            {
                for(int j=1; j<=6; j++)
                    dp[i]+=dp[i+j];
                dp[i]=dp[i]/6.0+1;
            }
        }
        printf("%.4f\n",dp[0]);
    }
}

转载于:https://www.cnblogs.com/martinue/p/5490405.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值