poj 2591 Set Definition

Set Definition
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 8210 Accepted: 3740

Description

Set S is defined as follows:
(1) 1 is in S;
(2) If x is in S, then 2x + 1 and 3x + 1 are also in S;
(3) No other element belongs to S.

Find the N-th element of set S, if we sort the elements in S by increasing order.

Input

Input will contain several test cases; each contains a single positive integer N (1 <= N <= 10000000), which has been described above.

Output

For each test case, output the corresponding element in S.

Sample Input

100
254

Sample Output

418
1461
#include<iostream>
using namespace std;
int v[10000005];
int main()
{
int i, j, x, y, m;
i=j=m=0;
v[m++]=1;
while(m<=10000000) {
x=v[i]*2+1; y=v[j]*3+1;
if(x<y) {
v[m++]=x;
i++;
}
else if(y<x) {
v[m++]=y;
j++;
}
else {
v[m++]=x;
i++; j++;
}
}
int n;
while(scanf("%d", &n)!=EOF) {
printf("%d\n", v[n-1]);
}
}
 

转载于:https://www.cnblogs.com/w0w0/archive/2011/11/22/2258599.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值