A Simple Problem

 

Problem Description
For a given positive integer n, please find the smallest positive integer x that we can find an integer y such that y^2 = n +x^2.
 

 

Input
The first line is an integer T, which is the the number of cases.
Then T line followed each containing an integer n (1<=n <= 10^9).
 

 

Output
For each integer n, please print output the x in a single line, if x does not exit , print -1 instead.
 

 

Sample Input
2 2 3
 

 

Sample Output
-1 1
 

 

Author
HIT
Problem analyse:
This is very interesting math problem.In the equation " y^2 = n +x^2",  "x"and "y"are all variable, so it's hard to handle it.
So first we can use the equation to reduce the varibles:
y^2 = n +x^2 → n=(y-x)*(y+x)  and then we assume that (1) i=y-x;  and (2)y+x=n/i;  
with the equations (1) and (2),we can get a new equation x=(n/i-i)/2;
Now the problem is gonna easy!
  
#include<iostream>
#include<cmath>
using namespace std;
int main()
{
    int T;
    cin>>T;
    while(T--)
    {
        int n;
        cin>>n;
        int i;
        i=(int)sqrt(double(n));
        for(i;i>0;i--)
        {
            if(n%i==0&&(n/i-i)%2==0&&n/i!=i)
            {
                cout<<(n/i-i)/2<<endl;
                break;
            }
        }
        if(i==0)
            cout<<"-1"<<endl;
    }
    return 0;
}

 

 

转载于:https://www.cnblogs.com/heat-man/articles/2750405.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值