A simple problem解题报告

题目摘要:Dreamone has a lovely cat. The catcan comfort you if you are very dejected, she can also play with you if

you are very bored. So Dreamone loves hervery much. Of course, you bet, she can also make you trouble if

she wants to be naughty. This time, shecomes up with a simple problem for fun, just like this:

She has 2n toys. In her heart, she has useda number to stand for each toy, and for example, the 2n toys are

given like this:

A1、A2、A3、….A2n-1、A2n

She wants to divide them into two groups,where each group contains n toys. So we can use B1、

B2...Bn ,which are all from A1、A2...A2n ,to stand for Group One,use C1、C2….Cn ,whichare all from A1、

A2...A2n, to stand for Group Two. The catwants to know the minimum value S for the expression below:

S=|B1-C1|+|B2-C2|+|B3-C3|+...+|Bn-Cn|

As we know Dreamone is studying MaJiangrecently, so he has no time to solve the simply problem. But he

knows the 6th program contest of SWUST ison, so he turns to you for help. Can you help him?

题目大意:输入一个整数N,给一组数,长度为2N,用A数组储存。将A里的数平分成2组,每组N个数,分别存在B和C数组里,计算S=|B1-C1|+|B2-C2|+|B3-C3|+...+|Bn-Cn|

的最小值

输入输出要求

Input

The first line of input will be a positiveinteger C indicating how many data sets will be included. Each of

the C data sets will contain two parts:The first part contains a numbern(1<=n<=100000),and the second

parts contains 2n numbers ,which are A1、A2、A2n-1、A2n(0<=Ai<=1000(1<=i<=2n)),represented 2n toys

 

Output

For each case, output the minimum value Sfor answer.

输入输出样例

 

Sample Input

2

1

1 3

2

1 1 1 2

 

Sample Output

2

1


解题思路:将A数组元素排序,直接用sort函数即可,然后一个for循环解决问题。

代码

#include<iostream>

#include<algorithm>

#include<string>

using namespace std;

 

const int maxn=200000;

int A[maxn]={0};

int main()

{

       intC;

       cin>>C;

       while(C--)

       {

              intN;

              intS=0;

              cin>>N;

              memset(A,0,sizeof(A));

              for(inti=0;i<2*N;i++)

                     cin>>A[i];

              sort(A,A+2*N);

              for(intj=0;j<2*N;j=j+2)

              {

                     S=S+(A[j+1]-A[j]);

              }

              cout<<S<<endl;

       }

       return0;

}

解题感想:如题所说,a simple problem!

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值