2016中国大学生程序设计竞赛(ccpc 长春) Fraction【模拟】

Problem Description

Mr. Frog recently studied how to add two fractions up, and he came up with an evil idea to trouble you by asking you to calculate the result of the formula below:


As a talent, can you figure out the answer correctly?

Input

The first line contains only one integer T, which indicates the number of test cases.

For each test case, the first line contains only one integer n ( n8).

The second line contains n integers: a1,a2,an(1ai10).
The third line contains n integers: b1,b2,,bn(1bi10).

Output

For each case, print a line “Case #x: p q”, where x is the case number (starting from 1) and p/q indicates the answer.

You should promise that p/q is irreducible.

Sample Input

1
2
1 1
2 3

Sample Output

Case #1: 1 2

Hint

Here are the details for the first sample:
2/(1+3/1) = 1/2
 
题意:读入n,输入两行数,第一行是a数组的n个数,第二行是b数组的n个数,按照题目如图所示模拟计算过程,最后结果分数化为最简。
思路:模拟。最后分子分母除以它们最大公约数即最简。
#include<stdio.h>
int a[20],b[20];

int gcd(int a,int b)
{
    int m;
    if( a < b)
        m = a,a=b,b=m;
    while(a%b)
    {
         m = a%b;
        a = b;
        b = m;
    }
    return b;
}

int main()
{
    int T,t,t2=0,i,n,j;
    int x,y;
    scanf("%d",&T);
    while(T --)
    {
        scanf("%d",&n);
        for(i = 1; i <= n; i ++)
            scanf("%d",&a[i]);
        for(i = 1; i <= n; i ++)
            scanf("%d",&b[i]);
        x = a[n-1]*a[n] + b[n];//初始化分子 
        y = a[n];//初始化分母 
        t = x;
        i = n-1;
        j = n-2;
        while(i>0||j>0)//循环模拟计算过程 
        {
            x = y*b[i--] + a[j--]*t;
            y = t;
            t = x; 
        }
        t = gcd(x,y);//求两数最大公约数 
        printf("Case #%d: %d %d\n",++t2,x/t,y/t);
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/hellocheng/p/7512617.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值