2016 ccpc(长春) Sequence I (kmp)

Sequence I

Time Limit: 3000/1500 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 958    Accepted Submission(s): 370


Problem Description
Mr. Frog has two sequences a1,a2,,an and b1,b2,,bm and a number p. He wants to know the number of positions q such that sequence b1,b2,,bm is exactly the sequence aq,aq+p,aq+2p,,aq+(m1)p where q+(m1)pn and q1 .
 

Input
The first line contains only one integer T100 , which indicates the number of test cases.

Each test case contains three lines.

The first line contains three space-separated integers 1n106,1m106 and 1p106 .

The second line contains n integers a1,a2,,an(1ai109) .

the third line contains m integers b1,b2,,bm(1bi109) .
 

Output
For each test case, output one line “Case #x: y”, where x is the case number (starting from 1) and y is the number of valid q’s.
 

Sample Input
  
  
2 6 3 1 1 2 3 1 2 3 1 2 3 6 3 2 1 3 2 2 3 1 1 2 3
 

Sample Output
  
  
Case #1: 2 Case #2: 1
 

Source
 

Recommend
wange2014   |   We have carefully selected several similar problems for you:   5932  5931  5930  5929  5928

当时暴力过的,没想过kmp,太菜了
#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
#define maxx 1123456
int ne[1123456];
int s[maxx],t[maxx];
int p,sum;
void get_next(int l)
{
    int i=0,j=-1;
    ne[0]=-1;
    while(i<l)
    {
        if(j==-1 || t[i]==t[j])
        {
            i++;j++;ne[i]=j;
        }
        else
        {
            j=ne[j];
        }
    }
}
void kmp(int x,int ls,int lt)
{
    int i=x;
    int j=0;
    sum=0;
    while(i<ls)
    {
        if(j==-1 || s[i]==t[j])
        {
            i+=p;j++;
        }
        else
        {
            j=ne[j];
        }
        if(j==lt)
        {
            sum++;
            j=ne[j];
        }
    }

}
int main()
{
    int n,m,i;
    int ll;
    int tt;
    scanf("%d",&tt);
    for(ll=1;ll<=tt;ll++)
    {
        sum=0;
        scanf("%d%d%d",&n,&m,&p);
        for(i=0;i<n;i++)
        {
            scanf("%d",&s[i]);
        }
        for(i=0;i<m;i++)
        {
            scanf("%d",&t[i]);
        }
        get_next(m);
        int ans=0;
        for(i=1;i<=n;i++)
        {
            printf("%d ",ne[i]);
        }
        printf("\n");
        for(i=0;i<n&&i<p;i++)  //如果i大于p,就重复的找了
        {
            kmp(i,n,m);
            ans+=sum;
        }
        printf("Case #%d: %d\n",ll,ans);
    }

    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值