HDU 3903 Trigonometric Function(数学定理)

Trigonometric Function

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 125536/65536 K (Java/Others)
Total Submission(s): 693 Accepted Submission(s): 277

Problem Description
Give you a triangle ABC. Get more information in the picture below.

Now, give you 6 integers a, b, c, n, m and k. a, b and c are triangle ABC`s three edges. Can you judge whether the result of the following fraction is rational number?

Input
There are several test cases in the input data.
Each case is just one line with 6 integers – a, b, c, n, m, k (0< a, b, c, n, m, k < 10^4) separated by spaces. The input data ensures that sin(kC) will not be equal with 0.

Output
Each case output “YES”, if the result of the fraction is rational number, otherwise “NO”.

Sample Input
2
1 1 1 1 1 1
3 4 5 6 7 7

Sample Output
NO
YES

若n为有理数,那么cos(n)一定是有理数
cos( k*n )一定是有理数
sin(n)确不一定。
所以只要判断分母是不是有理数就好了,sin(k*n)

#include <iostream>
#include <string.h>
#include <stdlib.h>
#include <algorithm>
#include <math.h>
#include <stdio.h>

using namespace std;
long long int a,b,c,n,m,k;
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%lld%lld%lld%lld%lld%lld",&a,&b,&c,&n,&m,&k);
        long long int num=4*a*a*b*b-(a*a+b*b-c*c)*(a*a+b*b-c*c);
        long long int t=sqrt(1.0*num);
        if(t*t==num)
            printf("YES\n");
        else
            printf("NO\n");
    }
    return 0;
}

转载于:https://www.cnblogs.com/dacc123/p/8228785.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值