Problem 1001: Sum Problem

Thanks to drizzlecrj's suggestion, I turned to hdu for the primary practice. Hnu was another choice, but the server is too poor that a submitted problem is showed "wariting" all the time.

Problem Description
Hey, welcome to HDOJ(Hangzhou Dianzi University Online Judge).

In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + ... + n.

Input

The input will consist of a series of integers n, one integer per line.

Output

For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer.

Sample Input

1
100
Sample Output

1
5050
 
  
None.gif #include  < stdio.h >
None.gif
None.gif
int  main()
ExpandedBlockStart.gifContractedBlock.gif
dot.gif {
InBlock.gif    
int a = 0, b = 0;
InBlock.gif    
while(scanf("%d"&a) != EOF)
ExpandedSubBlockStart.gifContractedSubBlock.gif    
dot.gif{
InBlock.gif        b 
= 0;
InBlock.gif        
int i = 1;
InBlock.gif        
for(; i <= a; i++)
InBlock.gif            b 
= b + i;
InBlock.gif        printf(
"%d\n\n", b);
ExpandedSubBlockEnd.gif    }

InBlock.gif    
return 0;
ExpandedBlockEnd.gif}

Summary:
Easy as it may seem, I am starting off.

转载于:https://www.cnblogs.com/NickyYe/archive/2007/02/04/639868.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值