hdu 1075 What Are You Talking About

What Are You Talking About

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 102400/204800 K (Java/Others)
Total Submission(s): 31176    Accepted Submission(s): 10700


Problem Description
Ignatius is so lucky that he met a Martian yesterday. But he didn't know the language the Martians use. The Martian gives him a history book of Mars and a dictionary when it leaves. Now Ignatius want to translate the history book into English. Can you help him?
 

 

Input
The problem has only one test case, the test case consists of two parts, the dictionary part and the book part. The dictionary part starts with a single line contains a string "START", this string should be ignored, then some lines follow, each line contains two strings, the first one is a word in English, the second one is the corresponding word in Martian's language. A line with a single string "END" indicates the end of the directory part, and this string should be ignored. The book part starts with a single line contains a string "START", this string should be ignored, then an article written in Martian's language. You should translate the article into English with the dictionary. If you find the word in the dictionary you should translate it and write the new word into your translation, if you can't find the word in the dictionary you do not have to translate it, and just copy the old word to your translation. Space(' '), tab('\t'), enter('\n') and all the punctuation should not be translated. A line with a single string "END" indicates the end of the book part, and that's also the end of the input. All the words are in the lowercase, and each word will contain at most 10 characters, and each line will contain at most 3000 characters.
 

 

Output
In this problem, you have to output the translation of the history book.
 

 

Sample Input
START
from fiwo
hello difh
mars riwosf
earth fnnvk
like fiiwj
END
 
START
difh, i'm fiwo riwosf.
i fiiwj fnnvk!
END
 

 

Sample Output
hello, i'm from mars.
i like earth!
 
题意:第一个SATR到END之间,输入火星文翻译表,第二个SATR到END之间,输入多句火星文,要求你翻译输出
题解:
1、map(string,string)
2、字典树,在输入火星文翻译表时建树,在每建完一个火星文单词,就在后面记录对应翻译单词的下标
 

一、map

#include<iostream>
#include<string>
#include<string.h>
#include<map>
#include<cctype>
using namespace std;
map<string,string>p;
string a,b,s,ss;
int main()
{
    cin>>s;
    while(cin>>a)//输入对照表
    {
        if(a=="END")
            break;
        else
        {
            cin>>b;
            p[b]=a;
        }
    }
    cin>>s;
    getchar();//这里要接收一个回车,否则会格式错误
    while(getline(cin,a))
    {
        if(a=="END")
            break;
        else
        {
            int len=a.length();
            for(int i=0;i<len;i++)
            {
                if(isalpha(a[i]))//判断是否是字母
                {
                    ss=ss+a[i];
                    if(!isalpha(a[i+1]))
                    {
                        if(p[ss]!="")//如果是火星文,输出对应的匹配值
                            cout<<p[ss];
                        else//原文直接输出
                            cout<<ss;
                        ss.clear();
                    }
                }
                else
                    cout<<a[i];
            }
        }
        cout<<endl;
    }
    return 0;
}

 

二、字典树

#include<iostream>
#include<string.h>
#include<string>
#include<cctype>
using namespace std;
int tree[500010][26],vis[5000010];
int cnt=1,id,len,root,num=0;
string s,ss,a[5000010],b;
void insert()
{
    root=0;
    len=b.length();
    for(int i=0;i<len;i++)
    {
        id=b[i]-'a';
        if(!tree[root][id])
            tree[root][id]=++num;
        root=tree[root][id];
    }
    vis[root]=cnt;
}

int search(string ss)
{
    root=0;
    len=ss.length();
    for(int i=0;i<len;i++)
    {
        id=ss[i]-'a';
        if(!tree[root][id])
            return 0;
        root=tree[root][id];
    }
    return vis[root];
}
int main()
{
    cin>>s;//输入STAR
    while(cin>>a[cnt])
    {
        if(a[cnt]=="END")
            break;
        cin>>b;
        insert();
        cnt++;
    }
    cin>>s;
    getchar();
    while(getline(cin,b))
    {
        if(b=="END")
            break;
        for(int i=0;i<b.length();i++)
        {
            if(isalpha(b[i]))
            {
                ss=ss+b[i];
                if(!isalpha(b[i+1]))
                {
                    int t=search(ss);
                    if(t==0)//原文
                        cout<<ss;
                    else
                        cout<<a[t];
                    ss.clear();
                }
            }
            else
                cout<<b[i];
        }
        cout<<endl;
    }
}

 

转载于:https://www.cnblogs.com/-citywall123/p/11173083.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值