POJ2533:Longest Ordered Subsequence

Longest Ordered Subsequence


Longest Ordered Subsequence
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 31680 Accepted: 13848

Description

A numeric sequence of  ai is ordered if  a1 <  a2 < ... <  aN. Let the subsequence of the given numeric sequence ( a1a2, ...,  aN) be any sequence ( ai1ai2, ...,  aiK), where 1 <=  i1 <  i2 < ... <  iK <=  N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.

Input

The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000

Output

Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.

Sample Input

7
1 7 3 5 9 4 8

Sample Output

4


这是一道动归题。

n=3


1735948

dp[]=0;

1ap[1]=0
7dp[2]=1
3dp[3]=1
5d[4]=2
9d[5]=3
4d[6]=2
8d[7]=3

最后找出最大值然后加一;

详细实现例如以下:



#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>

using namespace std;

const int M = 1000+5;
int sequence[M];    //输入的数据
int dp[M];          

int main()
{
    int n;
    while(scanf("%d", &n)!=EOF)
    {
        for(int i=1; i<=n; i++)
            scanf("%d",  &sequence[i]);
        memset(dp, 0, sizeof(dp));          //初始化为0
        for(int i=1; i<=n; i++)
            for(int j=1; j<i; j++)
            {
                if(sequence[i]>sequence[j])
                    dp[i] = max(dp[i], dp[j] + 1);    //动归方程
            }
        int ans=0;
        for(int i=1; i<=n; i++)
            ans = max(ans, dp[i]);
        printf("%d\n", ans+1);
    }
    return 0;
}


转载于:https://www.cnblogs.com/mqxnongmin/p/10841138.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值