Longest Ordered Subsequence 最长有序子序列

Longest Ordered Subsequence

Problem Description
A numeric sequence of ai is ordered if a1 < a2 < … < aN. Let the subsequence of the given numeric sequence (a1, a2, …, aN) be any sequence (ai1, ai2, …, aiK), where 1 <= i1 < i2 < … < iK <= N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.

Input
The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000

Output
Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.

Sample Input
7
1 7 3 5 9 4 8

Sample Output
4

题目大意:求输入序列元素中,最长的有序子序列的长度。例:1 7 3 5 9 4 8 最长的有序子序列为 1 3 5 8,长度为4。

动态规划,在此题中动态规划计算的是截止到第i个的最长增序子序列,dp数组初始化为1,即截止到每个位置的最长增序子序列为1,然后遍历每个位置 i,及每个位置之前的元素 j ,如果之前的元素小于当前位置,满足状态方程:dp[i] = Max(dp[i], dp[j]+1) ,具体参见代码。

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#define Max(a,b) (a)>(b)?(a):(b)

//动态规划
//在此题中动态规划计算的是截止到第i个的最长增序子序列,
int main()
{
    int n;
    scanf("%d",&n);
    int a[n],dp[n];//dp 数组记录第i个数之前的最长子序列
    for(int i = 0; i<n; i++)
    {
        scanf("%d",&a[i]);
        dp[i] = 1;//每个位置的最长子序列初始化为1
    }
    for(int i = 1; i<n; i++)//从 1 开始遍历每一个位置的数
    {
        for(int j = 0; j<i; j++)//遍历第i个位置之前的数
        {
            if(a[j]<a[i])//如果小于,将第j位置的最长子序列加一与第i位置的最长子序列比较
                dp[i] = Max(dp[i],dp[j]+1);
        }
    }
    int m = 0;
    for(int i = 0; i<n; i++)
        m = Max(m,dp[i]);
    printf("%d\n",m);
    return 0;
}

  • 0
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值