已知面积求周长

Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u
 

Description

There is a piece of paper in front of Tom, its length and width are integer. Tom knows the area of this paper, he wants to know the minimum perimeter of this paper.
 

Input

In the first line, there is an integer T indicates the number of test cases. In the next T lines, there is only one integer n in every line, indicates the area of paper.
T\leq 10,n\leq {10}^{9}
 

Output

For each case, output a integer, indicates the answer.
 

Sample Input

3
2
7
12
 

Sample Output

6
16
14
程序分析:此题的题意由标题就可以知道是已知一个矩形的面积要我们求周长,但值得注意的是要求我们求最小的周长,所以我们要使有一个变量min保存最小周长。使用的方法就是令2*(1+N)为最小周长,然后如果发现还有更有的周长就把这个值赋给min,最后输出min即可。
程序代码:
#include<iostream>
using namespace std;

int main()
{
    int T,n,j,b,min;
    cin>>T;
    while(T--)
    { 
        cin>>n;
        min=2*(1+n);
        for(int i=2;i<i*i;i++)
        {
            if(n%i==0)
            {
                b=n/i;
                j=(2*(i+b));
              if(min>j)
                  min=j;
            }

        }
        cout<<min<<endl;
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/yilihua/p/4693088.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值